Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by mohammedB-5 10 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
January 27, 2019 at 9:32 pm #3133397

mohammedB-5

Hi Dear
i have added the video in the main language, (english)
but in the (arabic) language if i edit the product it will go to WPML multilingual woo-commerce edit . how i can the video to arabic also ???

and how to add the SEO setting to the Arabic product ??

simply, i need to edit the Arabic products using the default editor ? also the multilingual woo-commerce

January 29, 2019 at 12:02 pm #3139616

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. My apologies for the late reply.

The video is probably stored as a page custom field, unless it is stored as a wide site option.
If the video is set in the page level, please follow this documentation to locate the custom field holding the video and translate it.
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

If it is stored a site wide option or theme option, you will be able to locate it in the WPML->String Translation->Translate admin texts, please follow this article.
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Regarding the SEO String, i will suggest that you update Yoast to latest version.
hidden link

Let me know how it goes.

Best regards,
Jamal
WPML Support

January 31, 2019 at 1:29 pm #3148099

mohammedB-5

I Have a Problem in my website because of the WPML
before everything was ok , now i am not able to edit any product !!!!!!!
i need your help and there is no Chat !

January 31, 2019 at 1:51 pm #3148142

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Once a ticket is created it is not attached to chat anymore, if you want chat, you will need to create a new ticket and choose chat. But this might be deactivated for the moment as we have a large load of support tickets. However i will try my best to assist you with this issues.

My apologies, i did not mention, that you can switch to WooCommerce native editor in WooCommerce->WooCommerce Multilingual->Settings(tab).

Please also update WPML to latest version. It is very important to update all WPML and WooCommerce to latest version.

Also follow our documentation, which is available in several languages.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Let me know if there are still any issues with WPML. I will be glad to help.

Best regards,
Jamal
WPML Support

January 31, 2019 at 2:16 pm #3148247

mohammedB-5

its updated to the last version
i need solution please
when i deactivated the WPML i can edit the products
so this happened from the WPML , everything was OK and i do not know how this happened after i asked you the question of video !

January 31, 2019 at 2:29 pm #3148314

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Would you allow me temporary access to your website so i can check this my self.
Please fill the private details fields after a full site backup. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal
WPML Support

January 31, 2019 at 4:15 pm #3148726

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I checked the product "Food Bag Clips Sealer" and i see that it redirects to the Translation Editor, even if WCML is set to use WooCommerce Native Editor. See attached image(Screen Shot 2019-01-31 at 15.33.35.png).
This is because the product was already sent for translation using Translation Management.
See attached image (Screen Shot 2019-01-31 at 16.10.17.png).

If you create a new product and try to translate it you will be using the WooCommerce Native Editor. Try it to see.

To overcome this situation, you will need to complete the translation 100%. Then update product in original language and save, which will push it to translation, the pen icon will become a spinner, and you will be able to edit in native editor.

If this does not help, you will need to resign the current translation job then check it and cancel it in WPML->Translation Management.

Let me know if this resolves this issue.

Best regards,
Jamal
WPML Support

January 31, 2019 at 4:31 pm #3148822

mohammedB-5

Dear
also i am not able to edit the products in the english language , i think there is a problem caused by WPML, for example of you open the dashboard , the menus will not be appeared in the Mouse hover, but if you will go to the (plugins) it will be appeared ...

something wrong and i cannot understand that , but its caused by WPML

please !

January 31, 2019 at 5:03 pm #3148986

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Please give me an example of product and i will try to fix it and show you how i did it.

Best regards,
Jamal
WPML Support

January 31, 2019 at 5:12 pm #3149011

mohammedB-5

Please find the attached pictures

Picture (1) , showing (Loading), this will not go ... only loading , so i can understand that its related to the problem

Picture (2) , showing that if the mouse hover on (products) or any other menu , it will not show the sub menus .. so its related to the same issue

Picture (3) , if you will open ANY product, you will not be able to edit anything ,, only showing blank page !

i hope that you understand the issue , i need solution please ... i do not know how this happened

February 1, 2019 at 1:10 am #3150089

mohammedB-5

My issue is resolved now. Thank you!