This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 36 replies, has 3 voices.

Last updated by Riffaz 2 months ago.

Assigned support staff: Riffaz.

Author Posts
July 27, 2019 at 3:38 pm #4293887

khalidA-27

Hi
"/ar" suffix has been added automatically to the end of most of my site URLs, even English ones,
Example:
Normal URL hidden link
affected URL: hidden link
Not that only. Also, The new URL gives 404 error And this only appears in G Analytics. And there you can find for some URLs overs 1000 visits. All of them 404 and all of them have 100% bounce rate.
Resaving permalinks doesn't do anything
Have a look here
hidden link

Please help ASAP

July 28, 2019 at 6:48 am #4294899

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is because you have different SiteURL and HomeURL: hidden link

Please go to Settings > General and change the SiteURL and HomeURL to the same address: hidden link
In your case, make them both : hidden link

Then check the issue.

Let me know how it goes.

Regards,
Riffaz.

July 28, 2019 at 7:43 am #4294983

khalidA-27

Hi
Thanks for reply
Have a look here please
hidden link

July 28, 2019 at 7:47 am #4294987

khalidA-27

Sorry
The previous video with no sound
hidden link

July 28, 2019 at 1:52 pm #4295537

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details to check this closely.
The next reply is private.

Regards,

July 28, 2019 at 2:39 pm #4295573

khalidA-27

Please note that this issue only appears in G Analytics.
Site URLs work fine when you visit it. But every visit to any url appear in GA and its url added to it "ar" and when you visit this from GA it will give 404 page.
All current 750 pages that appear in GA I have redirected them to the right url. And I need to know what causes this to prevent it from happening in the future and not to waste more time
Thanks

July 29, 2019 at 8:31 am #4297751

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Very likely this may happen because of the redirection plugin : Redirection - hidden link
Disable it for a while and check your Google Analytics.
You have to clear the all cache as well.
And, it may take a while to appear correctly on GA.

Let me know how it goes.

Regards,

July 29, 2019 at 1:26 pm #4300173

khalidA-27

Hi
ِAt first, I didn't have redirection plugin because I was not in need for it.
I installed this plugin to redirect these urls that appear in GA. So, How come you say that the plugin is the cause?

Please Find a solution to this

July 30, 2019 at 8:49 am #4305857

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This was hapned to a user a long time ago because of a redirection plugin.

Please send some screenshots of your GA reports we can clearly see the URLs and the report.
So, our second tier will check this and get back to you.

Regards,

July 30, 2019 at 2:48 pm #4308711

khalidA-27

Hi
Here you can find today's report
hidden link

And As I mentioned before. I installed the redirection plugin around 5 days ago after this happened. reports from two months ago and more have the same issue

July 31, 2019 at 3:56 pm #4316275

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to second tier.
Please be patient till we get back to you.

Regards,

August 1, 2019 at 9:49 am #4320289

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I access the root of the site hidden link it redirects to hidden link

how did you setup this?

Regards,

August 1, 2019 at 10:43 am #4320719

khalidA-27

I don't remember really
It wasn't appearing at the beginning and I contacted you to add it and you told me how
My site is EN/AR So it supposes to en or ar after the domain.
If you want access to admin I can give you
But your late replies are not helping

August 1, 2019 at 10:50 am #4320751

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

So, do you mean you did not do it on purpose?

if you visit to hidden link it redirects to hidden link
- this happens without your knowledge?

August 1, 2019 at 11:17 am #4321039

khalidA-27

No
My site has two languages ar end en
When a customer visits my site he will find the page displayed in either ar or en. So he will find it like this
Riversworld.net/ar/
Or
Riversworld.net/en/
So, Displaying links like that I thinks it is normal. But the issue appears in GA as mentioned above

Thats the situation
If you need access to admin to have a look at settings I will give you.
Thanks

The topic ‘[Closed] Adding ar suffix to all urls’ is closed to new replies.