This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Patrick Cruz 3 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
April 12, 2019 at 7:08 pm #3601401

Patrick Cruz

I am trying to:

Send my pages for translations of EN-SG to SDL.

Instead, I got:

this service does not support this ISO code.

is it possible to add it to your list? hidden link

Thanks!

April 12, 2019 at 9:16 pm #3602055

Patrick Cruz

Adding this here. same error for:

ja-jp

Thanks!

April 13, 2019 at 6:32 pm #3605347

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

It seems the language codes used for the custom language are not correct as they need to fit the norm.

Please have a look at the following list:
hidden link

For Singapore the correct code would be spelled: en-SG
For Japan the correct code would be spelled: ja

So to test if "ja" works perfectly, please follow the below steps:
1. Go to WPML->Languages->Edit language
2. Add a new custom language for Japanese with the language code "ja "
3. Now send a new post for translation and see if the issue exists.

Let me know if you need further assistance.

Kind regards
Andreas

April 15, 2019 at 2:32 pm #3614021

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the 2nd tier support team.

I have asked the TP developers to add the "EN-SG" and "ja-jp" to the TP server, and I will update you once I get any updates.

Best regards.

April 15, 2019 at 3:34 pm #3614671

Patrick Cruz

Thanks guys. It would be best if you can add these languages on your end as we tried to be as consistent as possible on our end with the language-country ISO codes.

We already have pages created in these languages, WPML supports custom languages if I just need to change the "Default Locale" or the "hreflang" that's easy but if I need to change the language code that will not be ideal.

Language name [Code]
Arabic - sa [ar-sa]
Australia & New Zealand [en-au]
Chinese - cn [zh-cn]
Chinese - tw [zh-tw]
Czech - cz [cs-cz]
Danish - dk [da-dk]
Dutch - nl [nl-nl]
English [en]
English - sg [en-sg]
Finish - fi [fi-fi]
French - fr [fr-fr]
German - de [de-de]
Greek - gr [el-gr]
India - en [en-in]
Italian - it [it-it]
Japanese - jp [ja-jp]
Korean - kr [ko-kr]
Norwegian - no [no-no]
Polish - pl [pl-pl]
Portuguese, Brazil [pt-br]
Romanian - ro [ro-ro]
Russian - ru [ru-ru]
Spanish - mx [es-mx]
Swedish - se [sv-se]
Thai - th [th-th]
Turkish - tr [tr-tr]
United Kingdom [en-gb]

April 16, 2019 at 10:36 am #3621003

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have sent your request to our developers and will get back to you once I have any updates.

Best regards.

April 16, 2019 at 2:00 pm #3622667

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Our dev team has added the missing languages, so can you please go to WPML -> Translation Services, and click on "Refresh language pairs" and then try again to send your content to the SDL service.

Best regards.

April 16, 2019 at 5:25 pm #3624255

Patrick Cruz

thanks Ahmed! I'm checking this week if this does it.

April 17, 2019 at 4:58 pm #3633285

Patrick Cruz

Hi Ahmed. this did the trick. just noticed though en-sg have "ENE" as "Value" is it possible to change this to EN-SG ? or is this intentional?

Thanks!

April 18, 2019 at 2:15 pm #3639877

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the confirmation, and I'm checking with our developers about the possibility to change the value, and will come back to you.

Best regards

April 19, 2019 at 11:57 am #3645529

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have checked with the developers and it seems that this is the correct value, they have fetched it from the SDL service, so can you please check with them if it is correct.

Do you have any issue with the value as "ENE"?

Best regards.

June 14, 2019 at 10:16 pm #4024415

Patrick Cruz

Hi,

it looks like we need to have the values the same as we're having issues on our end where the translations are getting rejected.

please fix:

en-sg and th-th

thanks!