This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Unable to translate image alt tags or alt tag is missing in translation editor

Solution: You may try this alternative solution:

If you want to translate Alt Texts and Titles: - Go to Media Library - In the top bar menu, select your language of interest : http://take.ms/xI7qw - Select an image and edit its attributes.

Actually, when you change language on the top menu, you are also changing the language for Media library, so, every change you make in your images will be reflected in your selected language.

You can find more information here: https://wpml.org/documentation/getting-started-guide/media-translation/

This topic contains 2 replies, has 2 voices.

Last updated by larsR-7 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 7, 2018 at 2:23 pm #2793876

larsR-7

I'm trying to add alt tags to images that are missing them.

I've done the majority but some images have the alt tag field missing so I cannot do this.

I've attached a screenshot in the hope that this will help you diagnose the issue.

Many thanks

October 8, 2018 at 7:55 am #2794993

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please try this alternative solution:

If you want to translate Alt Texts and Titles:
- Go to Media Library
- In the top bar menu, select your language of interest : hidden link
- Select an image and edit its attributes.

Actually, when you change language on the top menu, you are also changing the language for Media library, so, every change you make in your images will be reflected in your selected language.

You can find more information here:
https://wpml.org/documentation/getting-started-guide/media-translation/

Regards,
Riffaz.

October 11, 2018 at 6:22 pm #2809455

larsR-7

That works, my issue is resolved now. Thank you!