This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The link is not displayed correctly. It is displayed in this format: http://www.domain.com/?page_id=1234

Solution: If you are using WPML Sticky Links, you must scan the links. You can see step by step in our documentation, the link below.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/sticky-links/

This topic contains 6 replies, has 2 voices.

Last updated by gregorK-3 2 years, 9 months ago.

Assigned support staff: Bruno.

Author Posts
August 8, 2016 at 9:57 am #993889

gregorK-3

Template is working perfect with WPML (Conversion theme) yet i'm noticing some strange behaviour in footer.

In WPML admin I added strings that are in admin screen (basicaly part of theme options, what to show in footer). Strings were not in theme translation before.

Now they show up nice in Strings translation, i can click on Translation, field for all languages open up with default text (default as entered in Theme Options for footer). I entered a link i.e. hidden link, save it and on my it shows hidden link

For all languages ..

Am I missing something?

Thank you

August 8, 2016 at 6:33 pm #994984

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

Have you tried to disable the non-WPML plugins to see if the problem persists?

Also, are you using any plugin cache? If so, you've cleared the cache of your site to see if the link will be displayed properly?

Please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

August 8, 2016 at 6:39 pm #994987

gregorK-3

I'll check cache and plugins in a minute ...

August 8, 2016 at 7:04 pm #994995

gregorK-3

hmm .. you know what is strange? As soon as i enter a url which points to existing page, it turns to page ID .. BUT .. not for all languages!? 🙁

Also directories work .. i.e. domain.com/it domain.com/de

Screenshot .. german works, italian not

August 8, 2016 at 8:20 pm #995149

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This seems correct as you are using the "WPML Sticky Links" plugin. You can see more about this plugin in our documentation: https://wpml.org/documentation/getting-started-guide/sticky-links/. The language links are not converted into ID, there is a translation?

Also, I did not see the problem in the screenshot you posted. It seems that both links are added. I will attach a picture for you to see.

Thank you.

August 8, 2016 at 9:09 pm #995270

gregorK-3

Yes they are saved, but on frontpage they are shown with page id (deafult languge) in url .. not permalink

August 8, 2016 at 9:15 pm #995274

gregorK-3

Huh .. rescanned sticky links .. turned on some stuff in settings and now it works 🙂

Thank you for support!