This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Itamar 1 month, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 27, 2019 at 8:44 am

kcpv

After we switched default language from NL to EN we tried to 'Synchronize attributes and update product variations' within WooCommerce Multilingual. When I press this button it throwns an error 500. See attached image.

August 27, 2019 at 10:17 am
August 27, 2019 at 10:19 am #4465005

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

This ticket has been inactive for quite a while, so I'm transforming this chat into a support ticket because I believe you're still encountering the problem. You'll still be troubleshooting the problem with me, and this way we will not lose any progress made so far.

Please, follow the procedure that I've added in my previous reply and tell me if it is solving the issue.

Thanks,
Itamar.

August 27, 2019 at 10:21 am #4465169

kcpv

Can you send the image again?

August 27, 2019 at 2:22 pm #4467617

kcpv

The attributes terms are translated but the attributes label aren't translated. How to translate label of attributes? It doesn't work the 'normal' way via WooCommerce Multilingual -> Attributes. See attached images. As you can see the original language is still NL.

Like I said: this problem has only been there since we changed the default language from NL to EN today...

August 27, 2019 at 7:45 pm #4469473

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry about the screenshot. Here it is again.
Can you please try the troubleshooting section?

If you need further help from me, please share with the access details again. They are not kept from the chat. A private message is enabled.

August 28, 2019 at 6:47 am
August 28, 2019 at 7:03 am #4471517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

If you have performed all the troubleshooting options in WooCommerce Multilingual and the labels are still not showing on the front-end, please try WPML's troubleshooting section.
Thank you for the extra information.

1. Take a backup of the DB.
2. Go to WPML -> Support -> Troubleshooting (link)
3. Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Set language information'
While on this section, you can also press the other buttons.
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Assign translation status to duplicated content'
- 'Fix terms count'
- 'Fix post type assignment for translations'

*** Please make a backup of your database before using this.***

If this doesn't help them, please explain to me where I can see the issue on the front-end of your site. Please asl, attach some screenshots.

Thanks,
Itamar.

August 28, 2019 at 8:34 am #4472251

kcpv

Pressed all the buttons but the problem still exists.

You can see the problem on every product page, like: hidden link

The attribute names are in NL: 'Kleur' should be 'Color' and 'Maat' should be 'Size' in language EN. The original language of the attributes is still NL (should be EN after we changed default language to EN yesterday). See screenshots.

August 28, 2019 at 9:02 am #4472671

kcpv

We solved the problem with the attribute labels.

August 28, 2019 at 9:02 am #4472675

kcpv

My issue is resolved now. Thank you!

August 28, 2019 at 9:50 am #4472933

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.

August 28, 2019 at 3:13 pm #4475425

kcpv

We switched back to default language NL for several reasons. Now we have the problem again with the attribute labels -> again they are in NL on the EN website. In the back-end all the translations are correct, even the original language is correct. But on the front-end the attributes aren't translated to English..

Can you take a look in the back-end if you can see what's wrong?

August 29, 2019 at 3:17 pm #4482237

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

If you say that things work on the back-end, it sounds like a classic cache issue. Please note that cache can also be on your browser. But currently, when I check your site, I don't see the problem. When I go to the English version of the product that you gave me as an example, the attributes labels are in English. Please see the attached screenshot.
Can you see that it is OK now?

Because this ticket was marked as resolved, I don't have the access details anymore. So if needed please share then with me again. I'm enabling a private message for the next reply.

Regards,
Itamar.