This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Alejandro 3 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 5, 2019 at 9:26 am #3958473

Manuel

I am trying to: I have received an email from wordpress built-in error detection

Link to a page where the issue can be seen: hidden link

I expected to see: Don't know

Instead, I got this email:

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPML Translation Management.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

June 7, 2019 at 11:30 am #3975903

Manuel

Hi there, I have the debug.log file, how can I send it to you?

June 7, 2019 at 7:37 pm #3978863

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, please upload it to the storage platform of your choosing (like dropbox or google drive or even wetransfer), set the link to public (only you and i will be able to see it) and then send it my way on your next reply.

I'll wait for it.

Thanks!

June 10, 2019 at 7:31 am #3985601

Manuel

Dear Alejandro, you may download the file here:

hidden link

Thank you!

June 10, 2019 at 11:27 am #3987119

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Can you try again? it says the link has expired. can you add a bit more time before it expires?

Thanks

June 10, 2019 at 12:02 pm #3987277

Manuel

Sorry about that Alejandro, I have reloaded and you may download the file here:

hidden link

Best,

m

June 11, 2019 at 10:24 am #3994179

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, i checked the log and i see 3 errors that happened yesterday and have been happening for a bit:

1) A problem with Jetpack:

Trying to get property of non-object in /wp-content/plugins/jetpack/sync/class.jetpack-sync-module-posts.php on line 147

2) A problem with SG's cache plugin:

PHP Notice:  Undefined index: path in /wp-content/plugins/sg-cachepress/core/Helper/Helper.php on line 198

3) A problem with our Language Switcher's template:

PHP Warning:  array_key_exists() expects parameter 2 to be array, boolean given in /wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-templates.php on line 71

I suggest you do the following:

1) If you can update your SG cache plugin, update it and try to spot that SG error again in the debug logs, if it's gone, then everything's ok, if not, then please ask your hosting support about it.

2) Disable jetpack for now and see if things improve a bit (if you get less admin-ajax requests)

3) i think this could be caused to caching on your site but it could come from our internal Language switcher caching. please go to WPML > Support > Troubleshooting > Disable Language switcher templates cache. (it's the first option you'll see in that page)

It will take while to see a decrease of the admin-ajax.php requests but in a day you should have results you can trust, check with your support too to see if there's something else that might be working correctly but it's still making too many requests (they will be able to tell you what plugin or file is amking the most requests)

Regards.

June 18, 2019 at 8:15 am #4041233

Manuel

Good morning Alejandro, sorry for the trouble. My website has problems again, I have reinstalled a copy of the htaccess file and now it works. You may download a copy of the latest debug dile here: hidden link

Best regards

June 19, 2019 at 11:03 am #4050951

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you disable Jetpack and update our plugins with the latest release (V4.2.7.1).

Then rename the debug.log file so we can start clean again and see if the problem is still happening, please.

Let me know how it goes.

July 1, 2019 at 7:54 am #4116199

Manuel

Good morning Alejandro,

The website didn't work this morning, I have replaced the .htaccess as usual to make it work again.
You may take a look at the most recent debug file here: hidden link

Thanks!

July 1, 2019 at 9:57 am #4117607

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You mention that when you change the .htaccess it works. do you have a copy of both the "wrong" .htaccess and the correct one so i can check them out and try to spot what's going on?

Thanks!

July 1, 2019 at 10:32 am #4117841

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I also just noted that i don't have access to your site anymore. can you please add the credentials in the fields below your answer, please?

Thanks.

July 2, 2019 at 10:59 am #4126025

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

So the problem with the .htaccess is that somehow it's getting re-written to include the /en directory.

The weird thing, though is that should only happen when the option "Usa la directory per la lingua predefinita" is active and the English language is the default language (in this particular case).

did you ever have that option active before?. however, that also happens when that option has been changed but the permalinks hasn't been resaved, so it has a different configuration but with no effect because of the "old" .htaccess file.

If that's not the case, then it could be a third party plugin that's creating the issue as you can see in here:
https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

(In that link there's also a way to fix that problem yourself)

Regards.

July 2, 2019 at 12:12 pm #4126641

Manuel

Hi Alejandro, honestly I can't recall having the "Use directory for default language" option active sice we've been using wpml with this website for some years and the problem has started a couple of months ago.
So, do you recommend me to add the "Temporary workaround for avoiding the language folder from being added" code to the functions.php of Divi?
Thanks!

July 2, 2019 at 3:23 pm #4128427

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Yes, i recommend you add that workaround, because if you didn't use the "directory for default language" option, then it could be that another plugin is somehow modifying the .htaccess and adding the "/en" to it. the code will help you prevent that.

Regards.