This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 24, 2019 at 12:57 pm #3673145

Michele

I am trying to:
set up a new multilingual website (website language Japanese, admin language English)

Link to a page where the issue can be seen:
website under development

I expected to see:
All the admin interface and options in English

Instead, I got:
when in Woocommerce >settings > shipping , the admin interface is in Japanese
same for some options in Toolset views

PS: this happens when I turn on woocommerce multilingual plugin

April 24, 2019 at 9:14 pm #3676993

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

In this case I recommend you to follow this steps:
- Edit your user profile -> Under Languages select the language you desire for the backend -> Save the changes.
- Activate Woocommerce Multilingual -> Go to WPML -> String Translation -> Search some of the strings that are shown in the wrong language -> Check if this strings are assigned to the wrong language (sometimes it happens that String Translation scan the strings and assign them to an incorrect language) -> If this is the case you can use the link that appear right above the result table in WPML -> String Translation and assign the right language to the domain.

Note: Don't forget to flush any cache memory that might exists after finishing the steps above.

Please let me know if you need further assistance.

Kind regards,
Carlos

April 24, 2019 at 10:58 pm #3677441

Michele

My issue is resolved now.

Not 100% sure what worked, but it seems like switching the default language to English and then back to Japanese did it.

Thank you!

April 25, 2019 at 12:51 am #3677617

Michele

I spoke too soon. I couldn't get rid of the issue.

I followed the steps you suggested and strings appears to be assigned to the right language.

the only plugins I have active are:
WooCommerce
WooCommerce Multilingual
WPML Multilingual CMS
WPML String Translation
WPML Translation Management

the issue appears only when WooCommerce Multilingual is active.

Translation Management's setting page is also affected.

April 25, 2019 at 2:03 pm #3683177

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

April 25, 2019 at 11:04 pm #3686261

Michele

I cannot do that, but thank you for the offer.

April 26, 2019 at 1:36 pm #3691009

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you create a staging site with a copy of the live site and share the credentials so I can take a closer look at the issue?

Regards,
Carlos

April 29, 2019 at 12:32 am #3699217

Michele

Carlos, thank you, I will try.
I need a few day (I am on a small vacation)
I will get back to you here asap

April 29, 2019 at 6:42 pm #3706173

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for keeping me updated.

I will be waiting for your message.

Regards,
Carlos