Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Sumit 4 years, 2 months ago.

Assigned support staff: Sumit.

Author Posts
March 11, 2017 at 3:33 pm #1227972

attiahA

Hello
i have some problems after latest update with WPML

but at the first i want a quick and direct solution
the latest problem with your support toke 2 weeks without any solution

I have a website in Arabic, and English

i want the dashboard to be always in English as usual , whenever i want to edit a post in Arabic the language of the admin dashboard change from English to Arabic Direction . please i need a solution to this i want English to be my default language in backend.

this is images from the problem

hidden link

hidden link

and the ideal must be like this

hidden link

before your replay
sure i set the following setting

"Set admin language as editing language." in the user setting page is unchecked.
My WordPress Install main Language is English Sure
WordPress Language in Setting > general > Site Language is English

the second problem with bodypress
in this link must be all courses in Arabic version

hidden link

but the Arabic course link to the English version

This is an Urgent problems for me please more attention

March 11, 2017 at 5:12 pm #1228007

attiahA

i'm waiting support response as usual
i hope getting fast replay in any post 🙁

March 12, 2017 at 11:23 pm #1228317

attiahA

related to BuddyPress with WPML

my Theme support write to me this

*****************************

Well I tried deactivating all third party plugin but it made not difference .We checked our code and found it to be returning a valid corresponding language post id(in arabic) from original post id(in english) .
We found that wordpess core function get_permalink is returning wrong link .

SO it seems that wpml might be doing something with it .
Can you please try contacting wpml support on this ?
Please share their response here .

******************************

This topic opened from 2 days without any replay or response

March 13, 2017 at 2:26 pm #1228917

attiahA

i confirm WPML Support is top support in slow and delay in replay

why 2 or 3 days for just reply

this is a live websites to your clients !!!!!!

March 14, 2017 at 10:06 am #1229708

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

Sorry for the late reply.

1. Can you please check what "Language" is set in Users -> Your Profile?

I tried to replicate the issue in my test install but I was not able.
When I edit an Arabic post everything is correct like in your last screenshot.

It may be caused by a conflict of some sort.

Try the following steps (preferably on a test site):
❌ Before proceeding please make a full website backup! ❌
- Disable all the plugins but WPML and its add-ons
- Set a default theme (eg. Twenty Sixteen).
- If the issue is solved, please re-enable the Plugins one after the other, and check the issue each time you enable a plugin.
It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming from a 3rd Party Plugin.

- Please report me when the issue comes back.

2. For the Course post type, the issue seems similar to this one:
- https://wpml.org/errata/unable-to-get-site-language-on-the-front-end-ajax-calls-when-user-is-not-logged-in/

Can you please check if the workaround proposed in the article fix the issue?

Thank you

March 14, 2017 at 11:02 am #1229763

attiahA

Hello
for

2. For the Course post type, the issue seems similar to this one:
- https://wpml.org/errata/unable-to-get-site-language-on-the-front-end-ajax-calls-when-user-is-not-logged-in/

i try it and not solve the problem

i try now in your steps in number 1

March 14, 2017 at 11:22 am #1229785

attiahA

Hello
open the private replay to me i will give you the access data to mirror from my website to test your solutions

March 14, 2017 at 2:12 pm #1230025

attiahA

Vincenzo

i can't check BuddyPress without the theme used

please give me a solution

i have mirror my website you can check with your self

waiting ...............

March 14, 2017 at 2:26 pm #1230049

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

March 14, 2017 at 3:59 pm #1230143

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello,

As you may know, I'm checking your website.

At the moment I found the possible cause of the issue with Courses page.
It seems caused by a conflict with the "BuddyPress Social Connect" plugin.
Once this plugin is deactivated I can see the correct posts in the Arabic Courses page.

I will update this ticket as soon as I complete my tests.

Thanks for your patience

March 14, 2017 at 4:53 pm #1230211

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello,

1. The issue with the Courses page is caused by a conflict with the "BuddyPress Social Connect" plugin.
This is connected to this known issue:
- https://wpml.org/errata/unable-to-get-site-language-on-the-front-end-ajax-calls-when-user-is-not-logged-in/

I applied the workaround showed in that article and the site seems working again.

This fix will be available in the next WPML version.

Can you please confirm that this issue is solved?

2. The issue with the RTL direction in the edit page is caused by the Yoast SEO Premium plugin.
I tried on my test install and I reproduced the issue while I'm not able to reproduce it with the free version of Yoast SEO plugin.

I'm checking this issue with our Compatibility team and I will update the ticket as soon as I have some news.

Thanks for your patience.

March 14, 2017 at 9:59 pm #1230415

attiahA

Hello
i will deactivate BuddyPress Social Connect now and i'm waiting your update for
The issue with the RTL direction

and i will wait for This fix in the next WPML version.

waiting your update

March 16, 2017 at 2:46 pm #1232179

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello,

I escalated this ticket to our second tier support.

They are already working on it.

As soon as there is some news we will update this ticket.

Thanks for your patience

March 21, 2017 at 11:23 am #1235602

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello,

just a quick update.

This issue has been escalated to our WPML developers team.

I will update the ticket as soon as I get some news.

Thanks for your patience.

March 29, 2017 at 3:45 pm #1242548

attiahA

no any replay in my problem to this time

your problem is miss compatibility with Yoast

please be more patience....

waiting