Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by empowerU 4 years, 9 months ago.

Assigned support staff: Bruno.

Author Posts
April 23, 2015 at 11:44 am #604759

empowerU

I am trying to: disable update notices to no admins

URL of (my) website where problem appears: hidden link

I expected to see: a way to restrict WCML update notices to Admins

Instead, I got: WCML translation update notices for all

How can I restrict the admin notices relating to WCML to Admin permissions' users? I can't (and shouldn't) have this update notices to Shop managers, it's confusing. I tried using restrictive code in my theme's functions.php, but it doesn't work with WCML notices. Neither a plugin like https://wordpress.org/plugins/update-notifications-manager/ (outdated) or even https://wordpress.org/plugins/stops-core-theme-and-plugin-updates/ could help. I had to completely stop updates (with https://wordpress.org/plugins/disable-wordpress-updates/) so that I can address this issue for good.

Look, I'm perfectly aware that my WordPress website, including it's WPML and WCML plugins, has to be updated. But I don't want non-admins, that can't do nothing about it, to be aware of outdated translation files, for instance.

I was hoping you already addressed this issue and have a great solution for it. Thanks.

April 23, 2015 at 5:11 pm #605014

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The message for updating is displayed only for administrators.

As a test, I changed the version of WPML in my test environment and added a user to the role "Shop Manager". The message for updating is not displayed. I will attach a picture for you to see.

Please, could you disable all non-WPML plugins and see if the problem persists? Also, you have changed the "Shop Manager" role?

If this is not what you are asking, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

May 9, 2015 at 2:35 pm #615583

empowerU

Strange, the notices just stopped. I can't replicate the behaviour but I'm sure notices where definitely appearing to Shop Manager role.