Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 40 replies, has 4 voices.

Last updated by julianZ-4 1 year, 8 months ago.

Assigned support staff: Andreas W..

Author Posts
January 25, 2020 at 3:10 pm #5361831

julianZ-4

Tell us what you are trying to do?

After update to new wordpress and theme version, some admin options are not longer translatable. I see them in WPML String translation, it says they are translated - but on the website the not translated text appears. hidden link

I already tried to delete these strings and re add them. I already tried to change language of strings in WPML.

That did not work.

Other translated admin options are still working fine

January 26, 2020 at 4:34 am #5364191

Riffaz

Hi,

Thank you for contacting WPML support.

please try this:
1. go to WPML > Theme and plugins localization
2. select the option "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" in localization option : hidden link
3. save
4. switch back to "Translate themes and plugins using WPML's String Translation only (don't load .mo files)"

This fixed the same issue for many users.

Your issue should be fixed.

Let me know how it goes.

Regards,
Riffaz.

January 26, 2020 at 11:52 am #5364819

julianZ-4

Thanks Riffaz

But I don't have an option like that: hidden link
I tried to chose another option, save it and then switch back - but this did also not change anything.

What else can I do?

January 26, 2020 at 12:23 pm #5364965

Riffaz

Hi,

Sorry, that option was removed in the newer version of WPML.

Could you pleas let me know and show some screenshots of the area that are not shows in the translated language in your backend?

Regards,

January 26, 2020 at 12:31 pm #5364967

julianZ-4

Hi Riffaz

Here some examples, some work, some don't.

hidden link

Or here: Translation of button-text works, but it does not "translate" the link: hidden link Before updating, both worked.

January 27, 2020 at 12:53 pm #5369943

Riffaz

Hi,

The same issue has been resolved by these steps to a user.
Please try and let me know: https://wpml.org/forums/topic/order-emails-are-not-translate/#post-5275789

Regards,

January 27, 2020 at 1:24 pm #5370073

julianZ-4

I tried it, still the same: hidden link // hidden link

It's not translating this string

January 27, 2020 at 2:10 pm #5370479

Riffaz

Hi,

Let me check this with the team and get back to you.

Regards,

January 28, 2020 at 11:07 am #5376583

Riffaz

Hi,

Do you have any cache setting in server or site?
If yes, clear them all.
Then try again:

1. Delete the string
2. Turn on Look for strings while pages are rendered: https://wpml.org/wp-content/uploads/2020/01/5275789-st.jpg
3. Go to WPML > Theme and Plugins localizations and scan the plugin / theme where it comes from
4. Go to WPML > String translations and find the auto-registered string and translate it
4. Turn off Look for strings while pages.

If that does not help:
Go to WPML String translations > admin text and just click apply, then come back to WPML > String Translations and check again.
This helped to a few users.

Let me know how it goes.

Regards,

January 28, 2020 at 11:55 am #5376847

julianZ-4

hi riffaz

i did both already, no change. we dont have caching. what else can we do?

January 29, 2020 at 6:26 pm #5386843

julianZ-4

Hi Riffaz

Migration is now complete, you can check it.

Best regards

Julian

January 30, 2020 at 7:04 am #5389959

Riffaz

Hi,

We need your site login details to check this.
Your live site login details is the migrated site details as well.
Please provide it in the next reply.

Regards,

January 30, 2020 at 1:38 pm #5392653

Riffaz

Hi,

Thank you for the details.

The migrated site really slow. site is really heavy/big.
I am unable to make the changes.
Is your live site also slow?

Could you please try this in your live site?
1. go to WPML > String Translations and click on "Translate texts in admin screens »" at the very bottom
2. search all the not-translated strings and uncheck them https://wpml.org/wp-content/uploads/tmp/String_Translation_Preispirat_WordPress_2020_01_30_19_01_31.jpg
3. scroll down and save
4. Install and activate 'WPML Translation management"
5. go to WPML > Settings and go to "custom XML tab"
6. add those admin texts there: https://wpml.org/documentation/support/language-configuration-files/#admin-texts
ex:

<wpml-config>
<admin-texts>
 <key name="rehub_option">
  <key name="header_six_btn_url" />
</key>
</admin-texts>
</wpml-config>

7. now go to WPML > String Translations and you will see this string there.
8. translate it and it should work.
9. do the same for other admin texts as well.

Let me know the results, please.

Regards,

String Translation ‹ Preispirat — WordPress 2020-01-30 19-01-31.jpg
January 30, 2020 at 1:49 pm #5392717

julianZ-4

Hi Riffaz

I did that - no change:

hidden link

hidden link

Yes, it's a bigger site with thousands of posts and comments, that's why it is slow on Cloudways. The original system is very fast because we run it on a fast server.

February 2, 2020 at 11:12 am #5407127

Riffaz

Hi,

Try to delete them https://wpml.org/wp-content/uploads/2020/01/5275789-st.jpg and scan then translate again.

Let me know the results, please.

Regards,