Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 40 replies, has 4 voices.

Last updated by julianZ-4 1 year, 10 months ago.

Assigned support staff: Andreas W..

Author Posts
February 2, 2020 at 11:39 am #5407161

julianZ-4

I already did that: hidden link

We have set up a staging system. Please mark my next answer as private so I can provide login details to it and then you can check yourself.

February 3, 2020 at 6:58 am #5409509

Riffaz

Hi,

The next reply is private.

Regards,

February 3, 2020 at 12:12 pm #5412545

Riffaz

Hi,

Thank you for the test site but how to go to your translated pages?
Even if we select FR in the backend it goes to your DE live site: https://wpml.org/wp-content/uploads/tmp/Pages_Pirates_des_Prix_WordPress_2020_02_03_17_33_50.jpg

And, all the links also go to your live site.
How to go the FR page of this? hidden link

Let me know please.

Regards,

Pages ‹ Pirates des Prix — WordPress 2020-02-03 17-33-50.jpg
February 3, 2020 at 12:21 pm #5412577

julianZ-4

You can access french site on hidden link

Links are working correctly for me: hidden link There are no links to live-site

February 3, 2020 at 1:07 pm #5412801

Riffaz

Hi,

You are using the same link/button in more than one place.

Add this code to your live site WPML > Settings > Custom XML tab

<wpml-config>
<admin-texts>
 <key name="rehub_option">
  <key name="header_six_btn_url" />
</key>
    <key name="theme_mods_recash">
  <key name="header_six_btn_url" />
</key>
</admin-texts>
</wpml-config>

Then you will see another button to translate.
Translate and check.
This does not work in staging site but I could not check further because the site freezes when I go to WPML > String Translations

Please try it on the live site and let me know the results.

Regards,

February 3, 2020 at 1:28 pm #5412903

julianZ-4

That does not work. But it's expected behaviour because theme_mods_recash is old child-theme and is not used anymore.

I can access String Translations and Settings on Staging System without problems: hidden link hidden link

February 5, 2020 at 7:09 am #5427555

Riffaz

Hi,

Our second tier support is checking this now.
Please be patient till we get back to you.

Regards,

February 5, 2020 at 3:29 pm #5431891

julianZ-4

Hi Riffaz

OK, how long will this take?

February 6, 2020 at 6:49 pm #5441737

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, I am Marcos and I am taking care of your ticket today. I've checked our second level support reply and it seems the issue is now solved. Here are the details from our second level support.

1 - All the plugins in your staging website were deactivated and activated again, after this action the translations for the header button url seems to be working fine.

2 - Most likely the issue was related due a sort of cache in your server environment.

3 - You are also running Loco Translate plugin in your WordPress installation which is not compatible with WPML Sring Translation.

Please, let me know if you still have any questions regarding it. Have a nice day.

February 7, 2020 at 8:15 am #5444867

julianZ-4

Hi Marcos

1 - Unfortunately, that is not true. They did not activate the plugins again - so they p.e. removed the password protection of our staging site..

When I activate all plugins again, it does not work anymore with the translation of this button and others.

I investigated this myself: The deactivation of required plugin "REHub Framework" solves the problem (all other plugins are activated).

But I need this plugin "REHub Framework" to be active. It includes all our theme functions.

How can we proceed?

2 - We can rule this out, because the plugins were not activated again. Upon activation of all plugins, the translation does not work anymore.

3 - It worked just fine until now and still works fine. Deactivating Loco Translate would be an option for us, but deactivation of Loco Translate does not help with translating these button-urls. I deactivated only Loco Translate for a test. Still, the translation does not work.

February 7, 2020 at 9:55 pm #5450407

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We are sorry for the misunderstanding.

Please install your theme and any plugin necessary in order to recreate the issue including the Plugin REHub Framework onto the following test-site:

hidden link

If we can recreate the issue on this new WordPress Install we will be able to investigate further together with our compatibility team and through following up with the plugin author, if necessary.

Kind regards
Andreas

February 7, 2020 at 10:50 pm #5450515

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please leave me short notification once the theme and plugins, which are necessary to recreate the issue are installed on the earlier provided test-site (Access-Token in last message) in order for us to investigate this issue.

Kind regards
Andreas

February 8, 2020 at 2:34 pm #5452881

julianZ-4

Hi Andreas

I think you just need to install rehub theme as well es the rehub framework plugin in order to recreate the issue.

You can also see the issue on our testsite (details provided some messages earlier). There you can just deactivate all plugins except the rehub framework and you'll see the not working integration.

In the meantime, I also spoke to the theme developer. He thinks it's his themes fault and he will release a new version of the theme / plugin next week.

February 10, 2020 at 5:15 pm #5463651

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Yes, indeed. It is most likely related to the ReHub Framework plugin, but as this is a premium plugin I do not have access to the latest version.

Unless the theme author will be able to provide a fix in a short time, please use this access token to install the theme for testing. I can escalate towards our compatibility team which will collaborate with the theme author if needed.

Once-Click-Login:
hidden link

Leave me shot notification once the theme is installed.

Kind regards
Andreas

February 11, 2020 at 8:00 am #5466925

julianZ-4

Thanks Andreas. It's installed