Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 40 replies, has 4 voices.

Last updated by julianZ-4 1 year, 9 months ago.

Assigned support staff: Andreas W..

Author Posts
February 11, 2020 at 3:08 pm #5470727

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Julian,

I was able to find out, that as an example the Footer Copyright notice neither translates on our test install.

Could you please assist me with the important strings that you been trying to translate and let me know if you experience the same on this test-site? Please recreate the same site sections that are showing issues on your live-site.

hidden link

Kind regards
Andreas

February 11, 2020 at 4:08 pm #5471225

julianZ-4

Thanks Andreas.

I have added the necessary strings to translate - they show up on top of String Translation page.

Best regards

Julian

February 11, 2020 at 10:48 pm #5472833

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thanks a lot.

I was actually looking for a header template but I can see that all this information is coming from the theme options only.

What I did:

I copied the default language logo URL and started a search by using the String Translation text search field and marking the checkbox "Exact search".

I received 3 more string results that asked for a translation update. When I translated those strings the logo appeared translated. (See screenshot "Logo")

Then, I did the same for button text "submit a deal" and another untranslated string showed up, which I translated successfully. (See screenshot "button text")

Now, when it comes to the button URL I was not able to translate it.

I also recognized a theme issue between theme options and Front-End Customizer:

If I change the logo image inside of the Customizer it will not be updated inside of the theme options, which might be the reason why WPML is not able to translate it properly.

In fact, when updating the Logo in the Customizer I do not see the changes on Front-End, not even in the default language.
Now, if I add a new Logo inside of the theme options while having the site language set to German (top admin bar), the edits will be taken for the English language.
I try to say with that, that the theme seems not to be WPML ready and does not support multilingual theme options.

At the moment I do have two separate logos, I used to have two separate button texts.

The button URL is not translating. Neither, the footer copyright text translation is working.

If you would like to add something to this investigation please let me know. I am escalating towards our compatibility team and I will be in contact as soon I received feedback.

Further, I would suggest you reach out to the ReHub Theme Support and invite them to join our GoGlobal Program in order to solve any possible issues in regards to theme compatibility with WPML, as the theme has not been tested with our plugins yet.

Please pass the following link to the ReHub Support Team and explain the issue:
https://wpml.org/documentation/theme-compatibility/go-global-program/

Plugin not yet in our list:
https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=0&wpv-theme-category=0&wpv_post_search=&wpv_paged=23

Kind regards
Andreas

button text.JPG
Logo.JPG
February 12, 2020 at 4:06 pm #5479047

julianZ-4

Thanks a lot Andreas for investigating this further and in depth!

Let's hope the theme developer reacts fast..

February 12, 2020 at 4:46 pm #5479425

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Julian,

It might be possible that our compatibility team will come up with a workaround before the intent to contact the theme author.

I will keep you updated.

Kind regards
Andreas

March 27, 2020 at 1:49 am #5774563

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

As mentioned already. our compatibility team asked me to recreate the issue on a new install of WordPress but for some reason, this test-install got damaged.

In order for our team to find a solution, I do need you to install Rehub Theme in its latest version here:

One-Click-Login:
hidden link

Please install the default theme version and its plugins, no child theme or custom versions.

Also, take note that if the issue is Child theme-related, then this goes into the custom coding request category and is out of scope for our support policy.

I hope for your understanding.

Kind regards
Andreas

March 27, 2020 at 6:06 am #5775615

julianZ-4

Hi Andreas

I have installed the latest Rehub Theme version. As far as I know the issue is not Child theme related.

Best regards

Julian

March 28, 2020 at 5:56 am #5784457

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Julian,

Please take a look, as I have send a private message.

The issue does not occur on our test-site which for it might be related to the Child Theme or another plugin.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results. In case the debug-log is very long please add it to a web tool like pastebin.com and send me the link.

Kind regards,
Andreas

March 28, 2020 at 11:48 am #5784923
julianZ-4

Hi Andreas

Thanks for your feedback!

I think the theme developer made some changes to rehub theme for some of the necessary fields (p.e. the button). This is working on my live system now, too.

But I still have problems with the logo file: hidden link

I have changed the logo file on Cloudways in string translation, but on both versions (French / German) the same logo shows up.

On the live installation (Preispirat) I will need to have a translated logo, because in German, it's called "Preispirat" and in French it's called "Pirates des Prix"

Best regards

Julian

New threads created by Andreas W. and linked to this one are listed below:

https://wpml.org/forums/topic/split-theme-logo-not-translatable-on-st/

March 31, 2020 at 2:20 am #5800433

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Julian,

As we been handling various issues and a couple of escalations son this ticket I decided to open a new ticket for the Logo issue.

As the button link issue seems solved now, could you please consider this ticket as solved?

I will be answering on the new ticket in regards to the Logo issue.

Kind regards
Andreas

March 31, 2020 at 8:11 am #5801759

julianZ-4

My issue is resolved now. Thank you!