This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 year, 4 months ago.

Assigned support staff: Bigul.

Author Posts
May 18, 2018 at 9:39 am #2188665

alant-8

I want to set "English" as default language for admin panel.
And I don't find "Admin Language Setting" inside WMPL >Languages.

May 21, 2018 at 9:00 am #2199598

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Sorry for the late response due to a large number of support requests and weekend.

Please try the following steps and make sure you are getting the expected result or not.

1) Visit Users>>Profile
2) Choose *English* option for the *Language* field
3) Choose *Set admin language as editing language.* option for WPML language settings>>Editing language
4) Save the changes

Please check the attached image for more details and let me know your feedback.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 21, 2018 at 6:35 pm #2203766

alant-8

I tried already. But it's not the result of what i want.
I want to be English language as admin panel default language.

After I had edited some content for Chinese language , I need it to go back to page list (English language).

Thanks,
EMS

May 22, 2018 at 12:18 pm #2208016

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. Please share me a couple of screenshots for a better understanding of the issue.

Please note, if an admin visits a post/page in the frontend, the admin bar(on the top header) icons and links will be in the selected language of post/page. It is an expected result because of the following reasons.

a) It is hard to filter ONLY the admin bar to be in a specific language

b) If we do so it will lead to the performance issue, because we have to reload the Footer also

c) It is normal in WordPress that admin bar to be in the language that you are in the frontend

--
Thanks!

Bigul

May 22, 2018 at 4:24 pm #2210418

alant-8

Please see my screenshot. I hope you will understand very well about my issue. I also put 1,2 3 number in file name.Thanks.

May 23, 2018 at 1:00 pm #2215392

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details and screenshots. For your kind updates, it is an expected result because we are translating the Pages to Chinese manually. So the Dashboard language will be automatically switched to Chinese. As a workaround please try to translate the pages using WPML Translation Editor. Please try the following steps after a backup and check you are getting the expected result or not.

1) Visit WPML>>Translation Management
2) Choose *Multilingual Content Setup* tab
3) Scroll down to *How to translate posts and pages* section
4) Select *Create translations manually* option and save the changes
5) Then please try to translate a post or page

Please check the following documentation for more details.

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#translating-using-wpmls-translation-editor

https://wpml.org/documentation/translating-your-contents/creating-translations-manually/

--
Thanks!

Bigul