This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Raja Mohammed 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 17, 2019 at 9:25 am #4228167

behic-nuriS

I am trying to: I want an admin panel in my language

Link to a page where the issue can be seen:

I expected to see: I want all admin screen in English even editing pages in French or Turkish language.

Instead, I got: My admin panel language is switching to a language that I'm being editing. I've already selected English in User Profile and checked "Set admin language as editing language". It doesn't matter if I checked this. The Language option is switched to the language that I'm currently editing.

There is no debug info box in that page. I've attached pages screenshot.

WordPress 5.2.2 running

Installed Plugins
Elementor Version 2.5.16
Elementor Pro Version 2.5.9
Enable Media Replace Version 3.3.1
TablePress Version 1.9.2
WP Mail SMTP Version 1.5.1
WPML Multilingual CMS Version 4.2.7.1
WPML String Translation Version 2.10.5.1

July 17, 2019 at 10:54 am #4228919

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

Please uncheck the option "Set admin language as editing language" in your user profile, Enabling the option will override the language as per the language of the edited post/page.

I hope this helps you better.

Kind regards
Raja