This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Raja Mohammed 5 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 30, 2019 at 10:23 pm #3715085

angel-gabrielA

I am trying to: edit other language content in a multidomain site.

Link to a page where the issue can be seen: private site

I expected to see: other language admin page

Instead, I got: redirect loop

I have a domain per language site setup and when I try and edit the secondary language, it's asking me to login again. If I don't (just hit back) the site goes into a redirect loop whereby I think it's taking the secondary language code from the cookie and redirecting to that site, but then getting sent back as it's trying to login. and so it sticks in a loop.

May 1, 2019 at 4:44 am #3715957

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will take care of your issue,

WPML uses the iframe to share the session among all domains. You need to contact the hosting support to disable an x-frame option for the secondary domain.

You can find out more information here https://wpml.org/2016/04/use-wpml-different-domains-per-language/
Please scroll to the bottom and check
Session expires while switching languages section.

Once it is deactivated please let me know whether it solves your issue.

Kind regards
Raja