This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 27, 2019 at 11:29 am

Adam Rosenfeld

I am trying to:

Register an admin screen text in screen translation.

Link to a page where the issue can be seen:

hidden link

(this site requires a login. The user name and password both are: lawoffice)

I expected to see:

A greyed-out checkmark, indicating to me that this text has been registered for string translation.

Instead, I got:

No greyed-out checkmark. No matter how many times I select this text and click "Apply" at the bottom of the screen, it does not register for string translation.

August 27, 2019 at 12:05 pm #4466233

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Could you name the strings you are trying to register for translation? Or add some screenshots to show the strings?

Kind regards,
Carlos

August 28, 2019 at 7:06 am #4471519

Adam Rosenfeld

theme_mods_bb-theme-child >

fl-topbar-col1-text >

Call now: <a href="hidden link">03-3724722</a> | <a href="hidden link">055-9781688</a> | <a href="mailto:office@staging.cdpb3.flywheelsites.com">office@staging.cdpb3.flywheelsites.com</a>

August 28, 2019 at 10:15 am #4473241

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Please follow this steps:
- Go to WPML -> Settings -> Custom XML Configuration tab -> Add the following code:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_bb-theme-child">
      <key name="fl-topbar-col1-text"/>
    </key>
  </admin-texts>
</wpml-config>
- Save the changes

Could you confirm that the issue is solved?

Regards,
Carlos
August 28, 2019 at 10:44 am #4473563

Adam Rosenfeld

Thanks, it works now.

Could you please let me know why this happened, and if I need to do this for all admin texts in the future?

August 28, 2019 at 10:59 am #4473693

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

This probably happened because you need to increase the 'max_input_vars' value for the site or for some outdated cache memory. In any case you can read more about Language Configuration Files in the following link: https://wpml.org/documentation/support/language-configuration-files/

Regards,
Carlos