This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: the client wants to translate the metadesc-product and metadesc-page custom field created by Yoast plugin, but they do not appear in the Translation Editor when editing a page, nor in String Translation

Solution: The strings will appear in String Translation only if there is a default content saved. They can be found in Yoast -> Search Appearance -> Content types --> Products/Page and you need to write something before they can appear in String Translation. The same happens with the Translation Editor: since WPML works with translation, if there isn't anything in the default language you can't create a translation.

Relevant Documentation: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/ https://wpml.org/forums/topic/i-can-not-find-yoast-seo-title-meta-description-from-custom-filed/#post-2828286

This topic contains 13 replies, has 2 voices.

Last updated by carlP-11 11 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
October 5, 2018 at 9:40 am #2790206

carlP-11

I am trying to translate the attributes
- [wpseo_titles]metadesc-product
- [wpseo_titles]metadesc-page

Wordpress + Yoast SEO

Background:
I succesfully translated the [wpseo_titles]title-tax-product_cat] and [wpseo_titles]metadesc-tax-product_cat previously. I however ran into the problem when trying to find the metadesc-product and metadesc-page as they didn't appear in the String translation (neither by using the drop-down Admin_texts_wpseo_titles (22) or by show all & CTRL + F.)

Under 'Translate texts in admin screens' all the Names, including the ones above that I wish to translate are pre-ticked and greyed out.

In the wpml-config under wp-content/plugins/wordpress-seo: <key name="metadesc-post" /> were present, however not <key name="metadesc-product" />. (which I then added, but with no result)

I've browsed trough numerous threads, trying to find the solution.
One thread suggested to add the key names in the wpml-config.xml file (which is why I had a look in the wpml-file of WordPress SEO) to find one of them were already there.

Another thread (#1454112) hinted that I should be able to add the key names under
WPML -> Translation Management -> Custom XML Configuration
which I wasn't able to find (Maybe this is no longer an option in the current WPML?)

Can you assist?
Thanks in advance

Regards,

Carl

October 8, 2018 at 10:54 am #2795668

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

since WPML 4.0.0 the xml config has been moved to WPML -> Settings -> Custom XML configuration.

Could you try to add the key names there and see if this work for you?

October 8, 2018 at 12:37 pm #2795996

carlP-11

Hi Laura,

Thanks for the hint. I added the below XML under Custom XML configeration, which got verified as valid and added.

<wpml-config>
<admin-texts>
<key name="wpseo_titles">
<key name="metadesc-product" />
<key name="metadesc-page" />
</key>
</admin-texts>
</wpml-config>

However, The strings still don't appear in under String translation.
I also noticed that [wpseo_titles] appears under WPML -> Admin Strings translation - as "some strings maybe isn't registered" (in numerous versions) Below is roughly a 3rd of the errors. When clicking [Translate] I get directed to the String translation with an empty table.

[wpseo_titles: metadesc-product] sharing-options [translate]
some strings may not be registered
global [translate]
some strings may not be registered
sharing_label:

[wpseo_titles: metadesc-product] woocommerce_email_footer_text: {site_title}
sträng ej registrerad

[wpseo_titles: metadesc-product] woocommerce_new_order_settings [translate]
some strings may not be registered
subject:
heading:

[wpseo_titles: metadesc-product] woocommerce_customer_completed_order_settings [translate]
some strings may not be registered
subject:
heading:

[wpseo_titles: metadesc-product] woocommerce_customer_invoice_settings [translate]
some strings may not be registered
subject:
heading:
subject_paid:
heading_paid:

[wpseo_titles: metadesc-product] woocommerce_customer_new_account_settings [translate]
some strings may not be registered

October 9, 2018 at 7:11 am #2798513

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you give me your site's credentials so I can better check the issue? I'll enable a private reply.
Also, there is a post/page where I can see the untranslated strings?

October 18, 2018 at 7:06 am #2826846

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I found that these strings are in the admin translation strings (the link is at the bottom of the String Translation page).
You'll need to find them visualizing the source code because the strings are nested and it's a bit difficult to locate them.

Once you find them, you can select and send them to String Translation for actual translating. You'll probably need to increase your MaxInputVars value to save the page as it's big. I'd suggest at least 45000.

Let me know if this helps you or if you need further assistance.

October 19, 2018 at 9:21 am #2831342

carlP-11

Hi Laura,

Thanks for the prompt reply.

Could you provide me with more information/directions on how to "find them visualizing the source code because the strings are nested and it's a bit difficult to locate them."

as well as

"Once you find them, you can select and send them to String Translation for actual translating. You'll probably need to increase your MaxInputVars value to save the page as it's big. I'd suggest at least 45000."

----
I find them in the Admin String translation page - they're preclicked and no edits can be made.

October 19, 2018 at 6:20 pm #2832812

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'm doing a few test on a clean install to see how Yoast works.
I'll let you have news as soon as possible.

October 22, 2018 at 3:46 pm #2838744

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked on your site again and I found the metadesc-product also in this string: wpml-tm-custom-xml (see attachment).
However, the strings has this text:
"%%title%%, i lager hos oss på Fineshelf.com ✓ Sveriges exklusiva presentbutik ✓ Alltid fri frakt ✓ Snabb leverans"

which is already translatable (see attachment). I took it from here: hidden link

Also, notice you need to have something in your main language before you can see the field in the translation. Please see here: https://wpml.org/forums/topic/i-can-not-find-yoast-seo-title-meta-description-from-custom-filed/#post-2828286

About metadesc_page, I see it in the admin strings page, but it's empty. Probably it works similar to metadesc_product, so you need to insert something before you can see it.

Let me know if this helps you or if you need further assistance.

October 24, 2018 at 9:09 am #2845514

carlP-11

Hi Laura,

Thanks for your reply. I believe I might not have been clear.
Translating any of the meta-tags on product-level hasn't been the problem. (Your screenshot)

It's the custom meta-tags set in the yoast backend, which generates the meta-tags automatically to all pages, categories, products. Hence the parameters
%%title%%, in stock customcustomcustometcetc - since it can be applied to all products.

Today the pages+categories have automatically generated meta-tags (as they did appear in the String translation where a translation was added and it worked just fine) However the product pages doesn't appear there (as described in my first post) and hence can't be added to generate metadescription for all products.

Yoast -> Search Appearance -> Taxonomies --> Product Categories (these strings, so the ones mentioned in my first post, [wpseo_titles]title-tax-product_cat] and [wpseo_titles]metadesc-tax-product_cat - were found under String translation, translated and then applied to all Meta-titles and Meta-description for Product Categories in the Secondary languages)

Yoast -> Search Appearance -> Content types --> Products (I'm looking to translate this string, [wpseo_titles: metadesc-product] in order to achieve the same results as with the Product categories. A standard/custom Product meta-description also in the Secondary languages.

Hope this clear things up.

October 25, 2018 at 1:02 pm #2849863

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I followed your explanation and I added a custom Meta Description in Yoast -> Search Appearance -> Content types --> Products.
Then I found it in String Translation without problems (see ST_local.png).

Then I accessed your site with the credentials you provided and I found the string in String Translation (see Cattura.png). I don't know why I missed it earlier, but it's there.
The translation needs to be checked.
If you need to translate it in English, you have 2 option:

1. Change the description in Yoast -> Search Appearance -> Content types --> Products, writing it in English and then translate it into String Translation

2. Check the checkbox near the string, then below the string table, click on the button "Change the language of selected strings" and change it to Swedish or whenever language is. Then you'll find English between the language to translate into and you can add your translation.

The same applies to metadesc_page. If you can't find it in String Translation, it's because in Yoast -> Search Appearance -> Content types --> Page you didn't add anything.
Since WPML works with translations, if there isn't a default value you can't translate it, and you can't see the string in String Translation.

I hope this clear any doubts.

Let me know if this helps you or if you need further assistance.

October 25, 2018 at 3:35 pm #2850355

carlP-11

Thank you Laura for your help! I was also able to find the strings now under String translation (before there were 21 strings under [wpseo_titles] now there are 23 (one of them being [wpseo_titles]metadesc-product which is the one I needed)

I understand the logic that a default value needs to be there. If you check my screenshot, (Yoast -> Search Appearance -> Content types --> Products.png) you can see that there was one present also before. Could it have been something else you did which flushed the string translation (in lack of a better word) I'm having a similar problem with another string now (found it in admin screen, applied it but can't find it under string translation)

Best,
Carl

Nevertheless, thankful for your help and happy that it's finally solved.

October 25, 2018 at 4:55 pm #2850522

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I didn't change anything on your site, I just took screenshots so I don't know if it's my doing.

If you can find a string in the String admin page but after saving it isn't in String Translation, most probably is because you didn't save it. As I said in one of my previous posts, the string admin page is quite heavy and your MaxInputVars value is not enough to save it.
So I'll try to ask your hosting if it's possible to increase it up to 45000. If after increasing it you can't still save your string, please open another ticket and we'll be happy to help you.

October 29, 2018 at 2:02 pm #2858260

carlP-11

Ok!
Thanks again Laura. Have a great day.

October 29, 2018 at 2:03 pm #2858262

carlP-11

-