We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Jamal 1 month, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
September 3, 2019 at 9:55 am #4503159

chenZ

Hello Customer Support:
I want to translate the Home page which contains much text, but when I click on the + sign beside the Home on All Pages, WPML shows me a media translation screen like shown in this image hidden link instead of the advanced automatic translation one like this image hidden link
In this way, I cannot translate any text on the Home page because they are not shown after clicking on the + sign. In addition, the media translation page also gives me many text or images that do not belong to the Home page like shown in this image hidden link Could you please tell me where are those images and text from and why WPML wants me to translate something does not belong to this page?
Please let me know if you need my website credentials. Thank you for your help and have a nice day.

Best Regards,

Chen Zhao

September 3, 2019 at 12:12 pm #4504259

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

You can configure to use the Classic Translation Editor(CTE) or the Advanced Translation Editor(ATE) in WPML->Settings. We configure the editor for current content and new content, as shown in the attached image(cte-ate-settings.png). Please update this setting before continuing. Then because there is already an ongoing translation, you will need to either complete it first or resend homepage translation from WPML->Translation Management.

where are those images and text from . If the images were used before in the homepage, they get attached to it even after removing them from the homepage, that's a WordPress limit. WPML Translation Management offers to translate attached images. You will need to detach those images using a plugin or following this article
hidden link
For text except for image labels, I am not sure from where they came. It may need debugging.

and why WPML wants me to translate something does not belong to this page?
As expressed before, the images may still have a link to the page and that's why Translation Management offers to translate their labels.

I hope this helps. Let me know what you will get.

Best regards,
Jamal
WPML Support

September 3, 2019 at 12:15 pm #4504353

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

For text except for image labels(hidden link), they are coming from WPML->Packages, package 88. You have been building the page using a page builder(Elementor or Gutenberg blocks, etc.) WPML creates a package to store page builders fragments to offer them separately for translation. You may need to delete the package too.

Let me know what you will get.

Best regards,
Jamal

September 4, 2019 at 8:43 am #4509299

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Chen Zhao,

Thank you for sharing this video. Unfortunately, I am not able to log in, I get a 403 Forbidden error when trying to access /wp-admin or /wp-login.php or /login/ I suppose a security plugin is blocking me or my country IPs(Morocco).

In the meantime, I must say that the settings have helped us to partially resolve the issue. In the video, when you are trying to create a new translation for the homepage it was opened in the Advanced Translation Editor(ATE). Right!

For image names in the ATE, I believe that those images do not have a label, that's why WPML is offering their respective names as labels for translations. Please note that ATE won't offer to translate an image name or URL, only labels, If you update those images in Media Library and enter a label for each image, those labels will be offered for translation in ATE.

I am not sure why those images are "unattached" in the Media Library, maybe because they were added through Elementor(because elementor keeps its data in a custom field and does not attach the images like the WordPress "Add Media" feature).

I will also recommend that you remove completely any page in the trash for both languages, maybe one of them is still linked to another page as a translation. Removing completely these pages from the trash can void us several issues.

Please, also, make a database backup, then run the cleanup section actions in WPML->Support->Troubleshooting, which will remove any inconsistencies in the WPML tables.

Please check if you have a security plugin, or check with your hosting provider if he is blocking my countries, so I could be able to log in.

PS: I made your last reply private for security reasons. And I activated the private reply to share new credentials.

Best regards,
Jamal

September 6, 2019 at 7:16 am #4523585

chenZ

Hello Jamal:
Thank you for your fast reply. However, my problem has not been solved yet, and I really need your help. I recorded another video to show you the issue. Here is the video hidden link
I think that the reason why you cannot login is that WPML redirect you to the Chinese language login page which has not been setup or forbidden now. I deactivated the WPML plugin, and I hope that you can login this time. You can activate WPML after you login as the adminstrator.
Please let me know if you can login this time. If you still cannot login, please let me know so that I will figure out a way to let you in because I really need the help from an expert.
Thank you and have a nice day.

Best Regards,

Chen Zhao

September 6, 2019 at 1:35 pm #4525553

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Chen Zhao,

I logged in and activated WPML. Then I performed the following to no avail:
1. Removed Package 88 (88 is the ID the frontpage).
2. Removed the image from the page and saved.
3. Added the image again and saved.

It seems that the Advanced Translation Editor still keeps the old image title (Chen Zhao).
Please complete the homepage translation, you can keep the same titles for images or enter the Chinese title(good for SEO).
Then, make a small update to the page, and go to WPML->Translation Management to send the frontpage to translation again. This time It will have the new image title.

For the other Forbidden Issues, and according to our support rules, we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed.
I will create another ticket to handle those errors, but in the meantime, can you explain if the erroneous pages are specific to a plugin? Does that error appear with a regular WordPress page?

Looking forward to your reply.

Best regards,
Jamal

September 8, 2019 at 8:26 am #4530799

chenZ

Hello Jamal:
Thank you for your reply. I partially solved the Home page translation error, so I recorded this video to report my progress. Here is the video: hidden link
However, I still cannot see the Chinese Home page shows up on my site, and the forbidden error continue to occur on different random pages. Please let me know how to fix them.
Thank you for your help and have a nice day.

Best Regards,

Chen Zhao

September 9, 2019 at 3:13 pm #4538423

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Chen Zhao,

Regarding the Chinese homepage that is not updating, please update WPML to the latest release(published today) and try again to deliver the translation from ATE.
Check the browser console to see if there are any errors logged in there and activate PHP debugging to check if any PHP errors are written in the debug.log file.

Regarding the 403 errors and the Chinese menu, we should have different forum thread of each issue, for support rules we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed.
In the meantime, I'll try to give some hints, If it did not help, please create a new ticket for each issue, and you can assign them directly to me if you marked our latest ticket as resolved. Or you can ask in the ticket message to assign it to me.

For 403 errors, this could be caused by a plugin/theme conflict or by other causes, like a corrupt .htaccess file or incorrect file permissions, here two articles that can help with that.
- hidden link
- hidden link

Regarding the Chinese menus, I would need to activate WPML in order to investigate this issue. It is now deactivated on your website and I wonder if it is on purpose, I couldn't activate it before having your OK.

Best regards,
Jamal

September 12, 2019 at 9:09 pm #4564357

chenZ

Hello Jamal:
Thank you for your reply. The 403 error has been fixed after I deactivated and reactivated the WPML plugin even though I do not quite sure why this error can be simply fixed like this.
Now the only problem that I want to solve in this ticket is why the Chinese Home page does not show for Chinese site even though it has been translated. I will try to figure out other issues by myself first and may open a new ticket if I still need help.
I already activated WPML plugin on my site, and please help me to examine the Home page issue by logging to my site.
Thank you very much for your help and have a nice day.

Best Regards,

Chen Zhao

September 13, 2019 at 1:25 pm #4568825

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I checked the homepage and everything seems ok, and it should work, I guess that there is a hidden issue causing that. I would need to get a Duplicator copy of your website and investigate this issue locally.
Would you allow me to install Duplicator and take a copy of your website?

Best regards,
Jamal

September 14, 2019 at 6:26 am #4572301

chenZ

Hello Jamal:
I installed WP Staging and created a staging site 10 minutes ago. The access link for the staging site is yueke.ca/yueke-staging The login credential for the staging site is the same as what provided to you before. However, it seems like there are many warnings on top of the login page of the staging site, and I cannot login using those credentials.
In this case, please install the Duplicator and make a copy of my website. Please help me to examine and tell me the cause of this issue. Thank you for your help and have a nice day.

Best Regards,

Chen Zhao

September 16, 2019 at 11:51 am #4579899

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I could not log in to the staging site either. There are some issues with the Sabai and WPML extensions.
Now I installed Duplicator but I could not create a Duplicator copy, see that attached image.

Please follow the instructions in a private message(SEPTEMBER 16, 2019 AT 11:50 AM) to migrate your website into our platform. Once finished, please log in using your own credentials and check if you translate the homepage successfully. Let me then investigate further.

Best regards,
Jamal

September 17, 2019 at 4:33 pm #4590125

chenZ

Hello Jamal:
I successfully created a staging site for my website, and its website URL is yueke.ca/staging. Please login in the site using the following credentials:
[Credentials moved to private reply]
I also want to report that besides the Home page, the Chinese Mentor page also does not show up, and this may be caused by the same issue. Please help me to investigate. Thank you for your help and have a nice day.

Best Regards,

Chen Zhao

September 18, 2019 at 3:01 pm #4597795

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I logged in to the staging site and was not able to create a Duplicator package, because the size exceeded the 500Mb limit.

Please perform the migration to our platform, this will also help us exclude any possible cause from your actual server/hosting.

Please follow the instructions in my private message(SEPTEMBER 16, 2019 AT 11:50 AM) to migrate your website into our platform. Once finished, log in using your own credentials and check if you translate the homepage successfully. Let me then investigate further.

Best regards,
Jamal

The topic ‘[Closed] Advanced Automatic Translation not Show up but Media Translation Show’ is closed to new replies.