Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 1 year, 10 months ago.

Assigned support staff: Lauren.

Author Posts
March 13, 2019 at 5:59 pm

alfredoL-3

I am trying to:
Translate a page that uses ACF
Link to a page where the issue can be seen:
new.restauranterimini.com

I expected to see:
The same ACF that is in the original language in the translated language

Instead, I got:
Only default WP fields

March 13, 2019 at 7:36 pm
March 13, 2019 at 8:31 pm
March 13, 2019 at 8:32 pm #3338121

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I have sent you a private reply. Please let me know once the migration has been completed and I will further troubleshoot.

March 14, 2019 at 12:45 pm #3344517

alfredoL-3

I am getting this error when migrating:
Unable to access wpconfig file. Please check if WordPress is installed on the destination address. Also, check if you have permission to access the folder.

March 14, 2019 at 1:09 pm #3344777

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Okay, instead I can try setting up a local copy of your site for testing. To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

March 14, 2019 at 5:29 pm
March 14, 2019 at 6:45 pm #3347945

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

The fields were not showing because you did not have WPML Translation Management activated. Translation Management must be activated in order for Advanced Custom Fields Multilingual to work.

I activated Translation Management and then set a few of the fields to Copy. After reviewing the documentation here https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-simple-fields, you can see that fields set to Copy Once will not display in the Translation Editor, but they will display in the native WordPress page editor (manual translation). So, if you want them to display in the translation editor, you must set the fields to Translate.

To test this, I duplicated your homepage and duplicated the Field Groups for homepage. You can now see that when you edit the translated homepage, the fields that are set to copy (in WPML -> Settings) display in the translation editor.

Please let me know if you need any further assistance and I will be happy to help.

April 5, 2019 at 9:06 pm #3547049

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

This issue is now resolved as per the previous reply.