This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.82 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to add translation to a site with ACF fields. I expected to see the custom fields in the translation page when I click translate. Instead, I got only default wordpress fields are visible.

Solution: Edit the homepage, scroll down to the Custom fields section, select the Translate option for all the custom fields, hit the Apply button, and try again to translate the page.

This topic contains 17 replies, has 2 voices.

Last updated by Radu 1 month, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
August 9, 2019 at 6:30 pm #4372435

timothyR-11

I am trying to: add translation to a site with ACF fields and followed the instructions at https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Link to a page where the issue can be seen:

I expected to see: the custom fields in the translation page when I click translate

Instead, I got: Only default wordpress fields are visible.

I've installed the ACF multilingual plugin , Translation Mgmt plugin and String translation plugin.

August 12, 2019 at 5:13 am #4378429

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

Thank you for reaching out the WPML support!

If you already followed all the steps presented in this article https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/ but you are still not able to see the custom fields in the this side-by-side translation editor, I need to have a closer look at this and see why are things not working as expected. In this case, is there any chance that you could give me access to the dashboard area so I can check this, please?

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 13, 2019 at 12:43 pm #4388113

timothyR-11

What minimum user role do you require

August 14, 2019 at 8:08 am #4393093

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

It would be great if you could give me admin access. This way I'll be able to have a look at all the areas. I promise I won't make any change, I just need to check the settings.

Thanks,
Radu

August 15, 2019 at 11:14 am #4400405

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

Can you edit again the homepage, scroll down to the Custom fields section, select the Translate option for all the custom fields, hit the Apply button, and try again to translate the page, please? I did this for the homepage_tab_1 field, and it appeared when I tried again to translate the French version.

Please let me know how this goes.

Thanks,
Radu

August 15, 2019 at 11:59 am #4400633

timothyR-11

Hey Radu,

This appears to have worked after applying then saving the page

Regards,

August 15, 2019 at 3:46 pm #4402277

timothyR-11

The only remaining challenge has been to get the field page_title to appear in the translation

August 16, 2019 at 11:18 am #4406001

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

I'm glad to hear that everything works fine now.

I'll mark this ticket as resolved now. If you have any other question or issue, please open a new ticket and we'll take care of it in no time.

Wish you a fab one,
Radu

August 16, 2019 at 2:00 pm #4406827

timothyR-11

Hi Radu,

Did you check my last response

August 17, 2019 at 6:34 am #4409433

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

Sorry about this. I send my previous message without refreshing the page, and I didn't see your message.

Is there any chance that you could give me access to the dashboard area once again so I can have a look at the page_title field, please? Our system is made to delete the credentials once a ticket is marked as resolved (for safety reasons), so I no longer have access to the username and password you already send to me.

Thanks,
Radu

August 17, 2019 at 8:39 am #4409615

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

Can you tell me where I can see this page_title field, please? I edited the homepage but I couldn't see what's this element. Can you give me a few more details about this, please?

Thanks,
Radu

August 17, 2019 at 8:58 am #4409733

timothyR-11

Under Field Group Page Header, The Tagline field from that group appears but page title doesnt

August 19, 2019 at 6:37 am #4413697

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Timothy,

If we're talking about the field from this page (I can see now that it's set not to appear on the homepage) hidden link, then you should follow these steps in order to make it appear in the side-by-side translation page:

  • edit the translation;
  • add translation to all the fields;
  • make sure that you checked the Translation is complete field until the progress from the bottom is at 100%;
  • hit the Save & Close button;
  • make a little change to the original page (like adding one more point at the end of a paragraph);
  • Update the page;
  • edit again the translation.

Now you should be able to see the page_title field available for translation.

Please give this a try and tell me how things work now.

Thanks,
Radu

August 19, 2019 at 6:57 am #4413839

timothyR-11

Hi Radu,

Currently trying this with the about page. Field page_title still not appearing after following the steps you've outlined

Regards,

August 19, 2019 at 7:06 am #4413885

timothyR-11

Hi Radu,

Maybe there is something i'm not doing right, tried with the contact page and only field tagline is available, no other custom fields from the field group contact are visible.

Regards,