This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Andrés 10 months ago.

Assigned support staff: Andrés.

Author Posts
May 29, 2019 at 4:55 pm


I am trying to:

Translate Advanced Custom Fields

Link to a page where the issue can be seen:

Within WordPress admin

I expected to see:

ACF fields appear on their Spanish versions

Instead, I got:

I am not seeing the ACF fields translatable and finding some other issues (screenshot attached). I performed the following steps:

- Created a new ACF field group titled "WPML Test".
- Added two fields to the group, and set their Translation preferences to "Copy Once"
- Set the field group to show up for the "test en" page you created and saved the field group.
- Edited your "test en", populated the ACF fields, and saved the English version.
- Clicked the "Add Translation To Spanish" + button.
- Saved the Spanish version.

The ACF fields do not show up on the Spanish version page - I tried with and without the "WPML Translation Editor".

Also, for some reason a whole bunch of pages are now showing as duplicates (see screenshot).

May 30, 2019 at 8:33 am #3921357


Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

I just visited your site and it seems that you have not duplicated your custom fields in other languages. Could you go to to your Dashboard > ACF and duplicate your fields group as you woulr do with a regular page?


Best regards,

June 3, 2019 at 8:09 pm #3945897


Hi Andrés,

I'm not sure if you are saying I should duplicate the entire field group as in the attached screenshot? If so I'm not sure why I would need to do that, nor could I find any documentation on this in the link you provided.

June 4, 2019 at 5:15 am #3948023


Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

As you have set your ACF field groups as translate, you need to translate or duplicate them accordingly. Please check the first screenshot were your Spanish fields appears as empty while you have 27 in English.

As I mentioned before, for the duplicate them you would need to use the regular duplication option (screenshot 2) and not the one corresponding to ACF.

You can find more information about translating ACF groups here: