This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by 優介 前田 1 month ago.

Assigned support staff: Riffaz.

Author Posts
August 6, 2019 at 8:03 am #4344967

優介 前田

hidden link
でサイトを作成し、
hidden link
へ公開いたしました。

作成済の固定ページを修正し、Advanced Translation Editorを使用して英語のページも修正をしようと「翻訳を編集」したところ、Sourceに何も表示されません。
どのようにすればAdvanced Translation Editorを使って修正した文書を翻訳できますか?

August 6, 2019 at 8:34 am #4345277

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know if you need anything else regarding this.

Regards,

August 6, 2019 at 8:40 am #4345345

優介 前田

I'm sorry to be late.
I thought I could update after editing by clicking on the "Update translation" icon. But I can't.

August 6, 2019 at 12:37 pm #4347417

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It's ok.

What happens when you click on these update icons: hidden link

Let me know.

Regards,

August 6, 2019 at 10:08 pm #4350575

優介 前田

Thank you for your reply. I tried it.
It seems to work on my computer but not on the internet.

Can you see it because I attach it?

August 7, 2019 at 11:18 am #4354225

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

what is this https://wpml.org/wp-content/uploads/2019/08/4350575-01_16.jpg and what is this https://wpml.org/wp-content/uploads/2019/08/4350575-02_15.jpg ?
Are these two different pages that you are trying to translate?

As per your screenshots, I see you are using Advanced Translation Editor.
What do you see if you switch to classic translation editor and then try to translate?
You can switch here: hidden link

This is typical page hidden link right? not the custom post type?

Also, please provide your site WPML debug info for faster and better support: https://wpml.org/faq/provide-debug-information-faster-support/
I am enabling the debug info field for next reply.

Regards,

August 7, 2019 at 12:25 pm #4354981

優介 前田

https://wpml.org/wp-content/uploads/2019/08/4350575-01_16.jpg
↑ This is the display when I click "Update Translation" on the Internet

https://wpml.org/wp-content/uploads/2019/08/4350575-02_15.jpg
↑ This is the display when I click "Update Translation" in my local host

The purpose of the question is “Advanced Translation Editor does not work when a site created on a localhost is uploaded to the server”.

I switched to the classic editor.
It seems to be displayed as an attachment. If machine translation is possible from this screen, you can use the classic editor.

As you say, this page is not a custom post type.
But the same thing happens with custom post types.

Send debugging information.
Thank you.

August 8, 2019 at 7:29 am #4360319

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I understand the issue now.
You are having invalid ATE IDs in your databse.
This can be updated only by it's relevant department. 🙂

So,
1. when did you register the ATE ?
2. What was your site URL or domain when you registered it?
3. What is your site URL now?
4. What is the value when you run this query?

SELECT * FROM wp_options WHERE option_name LIKE '%WPML_SITE_ID%'

5. go to WPML > Settings > how to translate posts and pages

below the ATE settings there will be a link that will send you to a WPML site where you can check the translators permission. in that page there will be a menu on top of the page.

click on website and then go to "site identifier"

check that value and let me know.

Regards,

August 8, 2019 at 8:25 am #4360923

優介 前田

Thank you for your reply. There is an invalid ID.
Wasn't it good that I registered with my localhost and uploaded it to the Internet?

I will answer your question

> 1. when did you register the ATE ?
→ I registered on May 21, 2019

> 2. What was your site URL or domain when you registered it?
→ At that time, the URL of the site I registered was "hidden link"

> 3. What is your site URL now?
→ The URL of my site is now “hidden link

> 4. What is the value when you run this query?
→ I don't know the answer to this question. Sorry for lack of knowledge.

> 5. go to WPML > Settings > how to translate posts and pages
> below the ATE settings there will be a link that will send you to a WPML site where you can check the translators permission. in that page there will be a menu on top of the page.
> click on website and then go to "site identifier"
→ I confirmed.
URL:hidden link
Site identifier:35326331-6536-5831-a566-386433663762
It looks like this.

Thank you for your support.

August 8, 2019 at 8:30 am #4360957

優介 前田

I'm sorry.
Don't mind this reply

August 8, 2019 at 9:00 am #4361269

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

HI,

Thank you for the details.

5th is the issue.
Your URL for ATE is not same as your current site.
This should be changed.

Also, we need the value that I asked in 4
Are you using cPanel?
If yes, let us know the login details.
So we can check this our self and make the changes want.

The next reply is private.

Regards,

August 8, 2019 at 11:54 am #4362377

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you!

Still, need two more details.
1. your site login details (username and password)
2. how to access your database?

The next reply is private.

Regards,

August 13, 2019 at 2:51 pm #4388919

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for all the details.

I made some changes in your database.
Check if the ATE works in your site now.
I could not check ATE in your site because I see this when I go to your site login page: hidden link

If you still have the issue, let me know how can I login to your site.

Regards,

August 14, 2019 at 11:10 pm #4397941

優介 前田

Thank you for your reply.

I tried using Advanced Translation Editor earlier.
The state has not changed and is still not functioning properly.

I also confirmed that I was unable to log in to the site.
Unfortunately I don't have the authority to lift this restriction.

I try to contact another administrator, but he can't get in touch during a long vacation.
Can you tell me if there is another way?

Thank you.

August 16, 2019 at 6:50 am #4404923

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I tried using Advanced Translation Editor earlier.
The state has not changed and is still not functioning properly.
- if you can not login how do you check that the ATE does not work?

I do not think any other way to login the site except hacking the site 😉 which is really a risky and out of support scope.

Regards,