This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.58 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client could not open the ATE (Advanced Translation Editor).

Solution: Client solved the issue by opening these two URLs (ate.wpml.org and ams.wpml.org) up in their proxy (corporate proxy), as well as api.wordpress.org.

0% of people find this useful.

This topic contains 6 replies, has 2 voices.

Last updated by claireS-6 4 months, 4 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 15, 2019 at 3:07 pm #3818125

claireS-6

I am trying to: Use the advanced translation editor.

Link to a page where the issue can be seen: Local instance, cannot share a link.

I expected to see: The advanced translation editor for my page.

Instead, I got: The classic translation editor, even though I have the advanced one enabled. I switched to my instance that has nothing except ACF and WPML installed. (I also have ACF Multilingual, WPML String Translation, WPML Multilingual CMS, and WPML Translation Management installed)

For some reason, when I click on "Use WPML's Advanced Translation Editor" it has the spinning circle always there. Even if I shut down the server and re-start it, that spinning wheel is always there. I'm guessing this is the source of the problem. I moved to a clean instance with just WPML and ACF installed with the default theme and I am still having the spinning wheel problem. I thought this may be a proxy problem like my previous issue, but I connected on my phone hotspot and I still had the issue. I also made sure I had "Switch to Advanced Translation Editor" for older translations as well.

May 15, 2019 at 5:46 pm #3819195

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

My guess is that this issue might be related to the local setup in some way.

There are a few minimum requirements that need to be met:
https://wpml.org/home/minimum-requirements/

Can you please try to set up a WordPress setup on an online environment?

For example, I created this for you if you want to test things on it (one-click login):
hidden link

Hope that helps.

Kind regards,
Mihai Apetrei

May 20, 2019 at 3:04 pm #3848185

claireS-6

I did check and my local instance meets all of the requirements.

  • Wordpress 5.1
  • PHP 7.3.3
  • MySQL 8.0.15
  • I can create tables in the database, WPML has created some.
  • multibyte string and simplexml are enabled.
  • I am able to use the eval() function

Is there any way I can add my own PHP to this sandbox? My main issue has been with the ACF gutenberg blocks, so I want to see if the advanced editor will work with it. Also, is there any particular web address or server that needs to be hit for the advanced editor to be enabled? I am behind a corporate proxy and am wondering if that may be part of the problem.

May 21, 2019 at 2:34 pm #3856179

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi

Unfortunately, there is no way the PHP version can be changed on the sandbox I generated for you.

Regarding the ATE, yes, I can confirm that ATE automatically connects to the ATE server so I am sure that is the main reason why you can't get it working under the current corporate proxy setup.

We usually don't have clients that experience this issue that you are seeing at the moment, that is why I recommended you to try to set up a WordPress instance somewhere on an online environment so that you can see if it is working in that way (it should work on the Sandbox I generated, too).

I hope that this information helps.

Kind regards,
Mihai

May 21, 2019 at 2:40 pm #3856277

claireS-6

Can you please give me the URLs/IP Addresses of the ATE endpoints? If we open this up in the proxy then hopefully we will no longer have these errors.

May 21, 2019 at 2:49 pm #3856371

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

They are the ones below:

- ate.wpml.org
- ams.wpml.org

Kind regards,
Mihai

May 23, 2019 at 4:42 pm #3877971

claireS-6

I was able to resolve the issue by opening these two URLs up in our proxy as well as api.wordpress.org.