This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Mihai Apetrei 7 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 1, 2019 at 3:47 am #3258486

jeffreym-5

Advanced Translation Editor is being activated but never activates

i did all that is on your help files and still can not get it to activate,

see in this photo. it never changes

March 1, 2019 at 9:54 pm #3263251

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please elaborate a bit more on what happens when you try to edit a translation? Instead of the Advanced translation editor, you see the Classic translation editor? Can you please attach any screenshots, too? That would help.

Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 4, 2019 at 4:18 pm #3269841

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the credentials.

I was able to see and understand what you mean.

It feels to me that this might be a compatibility issue between one of the plugins/theme that you use and WPML.

Can you please try this:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

If you can't do that on the current site, I can create a testing environment for you where with just a few clicks you can duplicate the site on our servers. Just let me know if you would prefer that.

Please let me know what option would go best for you.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 6, 2019 at 10:47 am #3278244

jeffreym-5

HI

removing all plugins did not fix it,. its still not working. thaks

March 7, 2019 at 11:37 pm #3287790

jeffreym-5

you said " will duplicate the site and work in a separate, local development environment to avoid affecting the live site."

ok please do that and let me know, thanks

March 8, 2019 at 11:10 am #3291526

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the confirmation and for the updates.

Also, thank you very much for your patience. Our ticket queue is very full at the moment so that's why replies take more than usual.

I will then continue with the duplication of your site on a testing server and will get back to you as soon as I have updates.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

We will keep in touch.

Kind regards,
Mihai

March 11, 2019 at 12:06 pm #3310573

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I spent some more time on this issue and I also found a related ticket to the same issue.

Once the Advanced translation Editor is activated for the first time it is necessary to confirm the activation email sent to your registered email account.

Did you receive this email? In case not please try to send the email again and confirm it.

Please go to https://wpml.org/account/account-settings/ and confirm your registered email address.

Then please go to WPML->Settings -> How to translate posts and pages and click on "Resend Activation Email".

Then confirm the email.

Can you please let me know if this solved the issue?

Kind regards,
Mihai

March 11, 2019 at 2:28 pm #3313653

jeffreym-5

when i go to the below location "Resend Activation Email" is not showing at all

WPML->Settings -> How to translate posts and pages and click on "Resend Activation Email"

March 12, 2019 at 1:22 pm #3322461

jeffreym-5

Hi,

after 13 days try to get it to work im thinking i best move to Weglot , though i have speent $100 on this app, Weglot seems to have better support system so issues are fixed fast.

March 12, 2019 at 4:33 pm #3326459

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

We have been through a really full tickets queue and that is the reason why replies and the debugging process took more time. I do apologize for that and thank you very much for your patience.

I'm debugging on this with one of our developers right now. It seems that the ATE request from your site is in our logs already but something is holding ATE from activating.

I will get back to you very soon!

Kind regards,
Mihai

March 12, 2019 at 5:04 pm #3326759

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

My colleague confirmed to me now that this has been solved. It seems there was a miscommunication between the ATE on your site and our servers.

I went to the backend of your site to check now, too and things look fine.

Thank you for your patience and sorry for the waiting time.

Kind regards,
Mihai