This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Bobby 6 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
March 13, 2019 at 3:46 pm

fabianB-19

I am trying to:
While Advanced Translation Editor is configured for all cases, it does not open.

Link to a page where the issue can be seen:
"Pages" and translating the page "test" for example.

I expected to see:
I expect the advanced translation editor to open.

Instead, I got:
The normal translation editor side-by-side opens instead with a notice that the advanced editor can be configured for me. (see screenshot) But it is still configured for me. (see screenshot)
The editors sync in WPML settings gives an error, too. (see screenshot)

Hint: The site ran in an staging environment (staging-botschaftnamibia.kinsta.com) and was originally registered there, I think. The users are registered with the staging URL, too. (see screenshot)
But this cannot be the issue alone since the advanced translation editor does not work in staging, too.

March 14, 2019 at 1:43 am #3339135

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

This is a known issue that was resolved in our latest release of WPML 4.2.4.1

if possible please update your WPML version and let me know your results

March 14, 2019 at 3:01 pm #3346049

fabianB-19

Hi Bobby,

thanks for helping me.
I updated to 4.2.4.1 and the problem still persists.

Thanks in advance
Fabian

March 14, 2019 at 10:45 pm #3349005

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please try again , i have update the database entry that is responsible for the synchronization and have also done the sync for you which worked as expected.

let me know your results

March 14, 2019 at 11:43 pm #3349221

fabianB-19

Hi Bobby,

thanks, sync is working now.

But the advanced editor still does not open as desired. The user has access to ATE, WPML is configured to use ATE in all cases but it still opens the side-by-side editor and says that the user does not have access to ATE (which is not true).

Thanks in advance
Fabian

March 15, 2019 at 11:25 am #3353443

fabianB-19

Hi again,

I noticed that the ATE is now working for some pages but not for all.
Nevertheless I've configured to use ATE always in all cases.

For most pages it still does not work.

Greetings, Fabian

March 18, 2019 at 6:14 pm #3372263

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

our developers are currently aware of this issue and have been working on a solution , once i have some news i will be updating you here

March 18, 2019 at 7:14 pm #3372607

sandraT-8

I'm having a similar issue but ATE was working for me earlier today. I realized my custom fields were not loading in the ATE so after updating the ACFML plugin and WPML I followed all the directions here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Only the classic editor would open. Tried creating a new post with same results. Ending up deleting all the custom posts so I could start with a clean slate and then saw the issue with not being subscribed for me. Double checked the language settings for myself in translation manager, double checked on WPML.org.

I was running ACF Pro 5.8 beta and rolled back to 5.6 in case that was part of the issue.

Still getting message "This site can use WPML's Advanced Translation Editor, but you did not receive permission to use it. You are still translating with WPML's classic translation editor. Please ask your site's Translation Manager to enable the Advanced Translation Editor for you."

March 22, 2019 at 5:15 pm #3442811

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

we have recently released a beta version of WPML which should address many ATE related issues

please update and let me know your results

https://wpml.org/downloads/ . Then use the dropdown to switch to "Beta" versions

@sandrat-8 Please open a new thread in our forum and one of my colleagues will look into this for you to help you further

April 13, 2019 at 5:05 pm #3605299

fabianB-19

Hi Bobby,

I've discussed with our project lead but we cannot use beta versions here.
But we updated to the current version of WPML today which was released in the meanwhile.

I expect this version includes the changes the beta-version had at the time you posted here, Bobby. Right?

After updating today we still have the problem that everything works with ATE for pages/posts that were created after you fixed things here.
But pages/posts created before you fixed it still do not work with ATE.

tl;dr
The current version does not resolve the issue.

Greets, Fabian

April 16, 2019 at 6:17 pm #3624621

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

after some further tests and consulting with our developers at the moment this is still a known issue.

if a page was opened with Classic Translation Editor prior to activating the WPML Automatic Translation Editor you will have to create a new translation job in order to open it in ATE. (Advanced Translation Editor)

i just test this with the page "news" and it worked as expected

i went to WPML->Translation Management-> Send the page for translation and then took the translation job and it opened up in the ATE.

let me know your results please