Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Posts sent to the Advanced Translation Editor do not display as translated in the front end, even if they appear as translated in the backend.

Solution: In the pages there is a block returning a shortcode

[vc_btn title= " " color= "danger " align= "center " i_icon_fontawesome= "fa fa-file-text " add_icon= "true "]

Since the shortcode is empty, it blocked the pages to be displayed correctly.

This topic contains 5 replies, has 2 voices.

Last updated by julienD-32 2 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
August 29, 2019 at 8:06 am #4478545

julienD-32

When I launch Advanced Translation Editor on my articles written both with WPBakery and Gutenberg, only some text are translated.
I tried to change my wpml-config.xml like you explain on your website but it doesn't work. I also tried to use WPML Configuration Generator but it's the same problem. Can you help me ?

August 29, 2019 at 9:21 am #4479179

julienD-32

Migration is done !

August 30, 2019 at 2:41 pm #4487899

julienD-32

Hello Laura, did you find a solution ?

August 30, 2019 at 3:11 pm #4488091

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

since several tests we couldn't find a solution yet, so I'm escalating the ticket to the 2nd tier.

I'll let you have news as soon as possible.

September 3, 2019 at 2:43 pm #4505537

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

in your post pages there is a block returning a shortcode, but no content:

[vc_btn title= "Devis Assurance Voyage ou Expatriation en France " color= "danger " align= "center " i_icon_fontawesome= "fa fa-file-text " add_icon= "true "]

This was somehow blocking the translation to be displayed correctly. Removing it and redelivering the translation solves the issue.

September 3, 2019 at 2:56 pm #4505623

julienD-32

My issue is resolved now. Thank you!