This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Bigul 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 3, 2019 at 10:48 am

oksanaG-2

Hello

I have a problem with Advanced Translation Editor.

In WPML-> "Setting" when I choose "Advanced Translation Editor" it's not working. I enabled it but when I want to use it for translators, it just shows "normal Translation Editor".

I use many plugins for my site so I disabled all of them and even I turned WP theme to default but still, nothing changed.

I will add screenshots. Thank you for your help again.

Best regards,
Oksana

June 3, 2019 at 5:44 pm #3945051

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Please let me know the following details to track the issue.

a) Does it happen with all the Posts and Pages? Please try with a Page or Post that is not translated to any languages yet. Because now you are chosen *Classic Translation Editor* for the existing translated contents.

b) Please create a temporary Post or Page for a test, then check you are getting the expected result or not?

--
Thanks!

Bigul

June 3, 2019 at 6:23 pm #3945323

oksanaG-2

Hi Bigul

Thank you for helping!

I changed the option to " Switch to using the Advanced Translation Editor (old translations may be unusable)"

Also, I checked different posts and pages and even create a new page and also i checked it for different languages but still get the old "Classic Translation Editor" .

Alo I check it from my account as administrator and another account as translator but sill receive the same old "Classic Translation Editor".

How can I fix it?

Thank you!

Best regards,
Oksana

June 4, 2019 at 1:44 pm #3952101

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

Thank you for the updates. I have tried a few workarounds on your site, but it is not working at the moment. Because of it, we would like to check a couple of values in the Database.

Therefore please take a full site backup and allow me to install Adminer on your site, it will help us to connect your Database. Please check the following link for more details.

hidden link

--
Thanks!

Bigul

June 4, 2019 at 1:57 pm #3952161

oksanaG-2

Hi Bigul

Thank you for helping!
I already have a backup somewhere else so you can feel free to do whatever needs to be done.
You can install the Adminer too, no problem.

Best regards,
Oksana

June 5, 2019 at 8:27 am #3958061

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

Thank you for your permission. The issue is existing after initial checks. Therefore I have shared the details with our second tier team for the expert opinion.

We will get back to you soon. Please wait.

--
Thanks!

Bigul

June 5, 2019 at 9:30 am #3958493

oksanaG-2

Thanks, please let me know if I should do something to help.

June 6, 2019 at 7:29 am #3966489

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

We have a request. Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

June 6, 2019 at 10:09 am #3968085

oksanaG-2

Hi Bigul

As I wrote in the first message, I already tried this method and disables all plugins and returned to the defult theme but the problem did not solve by doing that.

I already have a backup somewhere else and gave you access to the site.
Please help me to find the problem!

Thank you!
Best regards,

Oksana

June 6, 2019 at 11:01 am #3968377

oksanaG-2

When I disable all plugins and return to the default theme it shows me another error in In WPML-> "Setting" when I choose "Advanced Translation Editor" :

"Unexpected token < in JSON at position 0"

I also get the same error when open WPML-> "Translation Management" -> "Translation Jobs"

It's just getting more and more interesting!

I will add a print-screen

June 6, 2019 at 2:45 pm #3970079

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

Thank you for the feedback. Please try the following steps and check is there any difference in the result.

a) Visit WPML>>Translation Management>>Translation Roles, add your self as a Translation Manager and Translator for few languages

b) Visit WPML>>Settings to sync the translation settings

c) Create a new Post or Page for test

d) Try to translate it

--
Thanks!

Bigul

June 6, 2019 at 3:16 pm #3970225

oksanaG-2

Hi Bigul

I already did it before with no result. But as you asked now I tried to do it again and still, there is no Advanced Translation Editor. It's just showing Standard Translation Editor.

Regards,
Oksana

June 6, 2019 at 6:53 pm #3971667

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

Thank you for the feedback. One more request. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 6, 2019 at 7:06 pm #3971685

oksanaG-2

Hi Bigul,

You can use the Duplicator plugin but I like to inform you that because this site is big sometime Duplicator plugin has a problem making big files. I recommend you to use All-in-One WP Migration plugin. I already installed it and made a backup file and you can use it or make another file as you decide. It's your choice to use any of these two plugins. I already installed it for you.

Please let me know if anything else needed!

Best regards,
Oksana

June 7, 2019 at 5:20 pm #3978165

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oksana,

Thank you for the details. I have tried with Duplicator and the issue is existing on my local server in a minimal setup(with the default theme and all other plugins were deactivate).

Therefore I am escalating the ticket to our second tier team for the further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] Advanced Translation Editor is not working’ is closed to new replies.