Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: error: api error unprocessable entity: empty value email

Solution: The problem happens because one/or more of the users on your site has a blank email, which WordPress does not allow. Set emails for all the users.

This topic contains 4 replies, has 2 voices.

Last updated by zigmundR-2 3 months ago.

Assigned support staff: Riffaz.

Author Posts
August 21, 2019 at 11:48 am #4430933

zigmundR-2

I am trying to: Switch from the Classic Editor to Advanced Translation Editor due to a few Chinese text inconsistencies that another of your Support team is helping me out with.

Link to a page where the issue can be seen: Within the WordPress WPML Settings environment, screenshot attached.

I expected to see: The green everything is ok message

Instead, I got: The attached shot of an API error message. I'm looking for the Translation Management Wizard within my WPML but can't find it

August 21, 2019 at 12:07 pm #4431117

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML.

The problem happens because one/or more of the users on your site has a blank email, which WordPress does not allow.
Set emails for all the users.

Please let me know if you are able to activate the Advanced Editor / classic editor after all users have an email set.

Regards,
Riffaz.

August 21, 2019 at 12:26 pm #4431277

zigmundR-2

Thanks so much Riffaz, I got the Enabled and Active message!

August 21, 2019 at 12:30 pm #4431393

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are welcome.

Please close this ticket.
A rating with a comment is appreciated.

Regards,
Riffaz.

August 21, 2019 at 12:33 pm #4431425

zigmundR-2

My issue is resolved now. Thank you!