This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 18, 2018 at 1:44 pm #2745262

marieW-2

I am trying to:
Translate my site from Swedish to English using ATE. It works fine at the ATE site, but when I click "finish" only parts of the translation is transferred. For example, the buttons change to English, but not the text. Everything is green and confirmed in ATE.

Link to a page where the issue can be seen:
hidden link
(Well, you can't see it, but that's the page I'm currently working on..)

I expected to see:
English translation in WordPress.

Instead, I got:
Swedish (the original) text.

---
When I go to the page I want to translate, it opens correctly in the ATE. I used machine translation, then corrected some translation that wasn't great. Clicked Finish in the end and was taken back to the Pages-page in WordPress.

I then changed my language to English (I'm translation from Swedish to English) and hit Edit on the page I just had translated. No luck. Most of the text - but not all! - is still in Swedish. I've tried to refresh or update the site, but no luck. Tried to resend the translation (it's still there when I open ATE), but it didn't help. Emptied cache on browser and site - no luck.

September 19, 2018 at 4:19 pm #2749442

Ricardo Alday

Hi,

Thank you for contacting WPML support.
I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Thanks,
Ricardo

October 2, 2018 at 11:42 pm #2782973

Ricardo Alday

The login info didn't work. Can you double check?
Although I think the problem is in the workflow. If you translate a page using Translation Editor or ATE and then go and edit it using the default WP editor you will lose all or part of the translation.

October 4, 2018 at 8:14 am #2786666

marieW-2

The login should work now, I don't know why it didn't.

The ATE doesn't show very clearly what fields I'm editing, and it sometimes cuts the text mid-sentence. To get a good flow and a correct text it's necessary to adjust it afterwards. If I can't do that through the editor, how can I do it?

Note that it works fine on some pages though, it's only some that causes an error.

October 4, 2018 at 6:52 pm #2788628

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Since Ricardo currently has a few days off, I will replace him here in the forum. I hope this is OK for you.

Thanks, the credentials worked (I got a DNS_PROBE_FINISHED_BAD_CONFIG error first, but then it worked). I will run some tests and send you a feedback soon.

Regards,
Diego

October 5, 2018 at 6:42 pm #2791535

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I did the steps below:
Deleted the existing translation of the (copy 1) page
- Went to Pages > All Pages
- Changed the language to english using the Language Switcher at the top admin bar
- Deleted the ensligh version of the page
- Deleted from the trash as well

Created a new copy of the page and translated
- Went to Pages > All Pages
- Changed the original language using the Language Switcher at the top admin bar
- Created a new copy of the page (MoreFlo IOS COPY 2)
- Translated the page to English (Using ATE), modifed some fields, published the translation
- Went back to the edit screen of the page (default language)
- Changed the language to English using the Language Switcher at the top admin bar (If it display a warning, click on "Edit Anyway")
- Apparently it is all ok in the manual editor (see screenshot)

Could you please check?

I also checked the settings of your server through debug log and saw that some items need attention:

Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Kind regards,
Diego

October 8, 2018 at 12:45 pm #2796007

marieW-2

Hi,
Thanks for looking at my issue, but I wonder what happened? I'm no longer able to see my pages in backend at all. (They're still available in front end.)

If I chose English in the Language Switcher, I can see them, but once I change to Swedish I'm getting a blank page. As most pages are not translated, I can no longer see them!

What might have caused this? I can also not see products, but I'm able to access the setting pages etc.

I'm given this URL when I change the language:
hidden link

Please help!

October 8, 2018 at 9:06 pm #2797329

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

If you change to the Swedish language, you should see only the pages that are already translated to that language. To create a new translation, you should switch back to the english language, then click on the "+ Icon".

Is that what's happening? If not, could you send me some screenshots so I can better understand the problem?

Kind regards,
Diego