This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by dariaK-2 2 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
July 29, 2019 at 7:47 am

dariaK-2

I am trying to:
I have a Divi theme installed and I'm trying to make some changes (to add a new word in a translated text, for instance) in the already translated French page with the help of ATE.
The initial translation from the original language (Russian) to French was also done with the help of ATE.

Link to a page where the issue can be seen:
- Russian page (Original language): hidden link
- French page (Translated): hidden link (it doesn't show the issue)

I expected to see:
French translation with the changes I made.

Instead, I got:
Text in the original (Russian) language.

July 29, 2019 at 11:03 am #4298951

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you check now?
hidden link

It seems to be working for me and I have opened the page in the incognito mode, so no caching (see the image). I have opened that original and clicked "Mettre à jour", so that the advanced translation editor expected translation update. After I redelivered the translation, it worked.

If this happens on some other page perhaps, you can try that as well. Sometimes there may be some delay or disrupted connection between your site and advanced translation editor (because it is an external service), maybe due to iThemes security plugins (some feature of its may be blocking some of the connections) or some similar reason.

Regards,
Bruno Kos

July 29, 2019 at 2:18 pm #4300791

dariaK-2

Thank you for your assistance! Your solution worked for the page "About me" and for "Contacts", but it doesn't seem to be working for other pages. I disabled iThemes plugin, but still hasn't been able to reproduce your solution for the Frontpage:
- French "Accueil": hidden link
- Russian (original) "Главная": hidden link

The same situation is with the page "Сеанс: Тетахилинг" (your solution is not reproducible here also):
- French "Séance : ThetaHealing®": hidden link
- Russian (original) "Сеанс: Тетахилинг": hidden link

Can you, please, check it also? Did I miss something in your solution?

Thank you in advance!

July 30, 2019 at 5:47 am #4304819

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I'm not sure what could be behind this, but I was able to get the homepage working also. I have modified some of the texts on the original (see image), and then the icon has changed which indicates that the translation it requires update. It was visible within translation editor and everything worked after this. Can you try doing it on other pages - so make some change on the original and then go to ATE.

Regards,
Bruno Kos

July 30, 2019 at 9:49 am #4306367

dariaK-2

Great, thank you for the help! Now Frontpage and the page "Thetahealing" can be translated via ATE. Probably there was some sort of cache or an obstacle on the WPML side and I figured out how you achieved removing that cached results:
1. Make any text change on the source page in the original language (important step since just clicking an "update" without actual text changes will not lead to the result)
2. Update the page
3. Use ATE to translate
Doing it once will lead to the ability to change the translation of the page without prior steps 1 and 2.
And that is awesome since it helps to actually solve the issue manually! So, thank you!

But I still have pages where that strange cached result appears if I don't follow these 3 steps and instead just trying to translate (make changes to translation) via step 3 without prior steps 1 and 2 (direct clicking to ATE without prior text change and updating of the original page). Here is an example of one of that page and the images (see the attached files) explaining how to reproduce the issue:
- Original (Russian) language page "Семинар: ДНК базовый": hidden link
- Translated (French) language page "Séminaire : ADN Base ": hidden link

The problem actually is that if a manager/translator accidentally will try to translate any of that cached/frozen pages by just clicking on ATE button, he can ruin the page since as a result the whole page will be in original language (instead of previously translated language) and we will need to do a backup or get back to that page and quickly go through the magic 3 steps mentioned at the beginning of the message. I suppose this is an issue which probably should be fixed in the next releases.

July 30, 2019 at 12:28 pm #4307623

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I think that this is an rare case, happening on your site for some reason. There were some examples of the sites with synchronization issues between ATE and WPML (similar as on your site), very often these have been related to caching or security plugins blocking various requests.

ATE team is working on the product all the time though and are always improving it when it comes to implementing various features, segmentation of content ( separation of the two content and stuff like shortcodes and various code samples used on the site) and also compatibility issues with various plugins and especially page builders.

Can you tell me if I can assist any further at this point?

Regards,
Bruno Kos

August 4, 2019 at 8:44 am #4335871

dariaK-2

My issue is resolved now. Thank you!