This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Advanced Translation Editor not showing translations Solution: - change permalinks from default to any other type - opened translations in ATE and redeliver

This topic contains 13 replies, has 2 voices.

Last updated by janettS 5 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
May 9, 2019 at 9:51 am #3774853

janettS

I am trying to: When i update a translation in ATE it only shows the first translation it made and not the updated one.

Link to a page where the issue can be seen: hidden link

I expected to see:The new text I have inserted

Instead, I got:When I change a text in a translation, ATE shows only the original,I have tried to use classic translation but when I go back to ATE it only remembers the original translation

May 9, 2019 at 10:03 am #3774933

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you show me for which page is this happening?

I have tried to use classic translation but when I go back to ATE it only remembers the original translation

As for this, we do not suggest mixing these two, as ATE is a separate system having its own translation memory.

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 9, 2019 at 11:47 am #3775735

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am able to log in. Can you show me for which page is this happening (or is this happening for any page I try)?

Regards,
Bruno Kos

May 9, 2019 at 2:08 pm #3776925

janettS

I've tested it on the page: about me. I have also tried to create a new page with the same result. When I try to edit in a created page, ATI will only display the original translation.
Regards Janett

May 9, 2019 at 2:37 pm #3777199

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Janett,

I am trying to: When i update a translation in ATE it only shows the first translation it made and not the updated one.

I tested this in the chrome incognito mode (so no caching) and this is what I found:
- crated this page: hidden link
- translated it using ATE: hidden link
- opened original and added "some new update added" to the title
- opened translation in ATE and it showed there, also showed on the original
- translated that string to: "BRUNO WPML testing ATE – some new update added – ENGLISH"

The issue here as I see it that nothing shows up on translation, apart from that title, but I see no issues with ATE at the moment.

Regards,
Bruno Kos

May 9, 2019 at 3:03 pm #3777491

janettS

Okay, I can see that it works, but it just doesn't come out on the page. I have put your test page up in a menu and the text does not appear in the English version.

May 10, 2019 at 11:25 am #3783621

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Okay, I can see that it works, but it just doesn't come out on the page

Yes, it doesn't seem to be working properly, even though ATE seems to be working.

Therefore, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

Perhaps it might be theme related (content not displaying on translations), so let's see if this is really the case.

Regards,
Bruno Kos

May 10, 2019 at 2:16 pm #3785379

janettS

Hi Bruno.
I have tested with all plugins turned off and it makes no difference.
I don't really know what you mean by this ? "theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme"
I have tried to create a new page where I turn ATI off and use WPML's Classic Translation Editor. In that case, it works as it should.
Regards Janett

May 10, 2019 at 2:58 pm #3785939

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your them

By this I meant that you do this:
- Appearance -> Themes -> (install) activate Twenty Nineteen theme
- visit hidden link

If the content is still not showing (so only "BRUNO WPML testing ATE – some new update added – ENGLISH" would be visible), then we can exclude that it is a theme compatibility issue.

Regards,
Bruno Kos

May 10, 2019 at 3:03 pm #3785961

janettS

I just tried activating twenty nineteen and there is still no text on the English page.
Regards Janett

May 10, 2019 at 3:14 pm #3786115

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can I ask you the following then? In order to debug this issue , can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

May 10, 2019 at 3:23 pm #3786189

janettS

That's okay, where should I upload the package?

May 13, 2019 at 9:51 am #3796589

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I downloaded the packages directly from the site and restore them on my localhost.

Can you check now?
hidden link
hidden link

(clear the browser cache or try incognito mode if you don't see it).

I tried the following on my localhost and it worked and then did the same on your live site:

- changed permalinks from default to Navn på indlæg hidden link
- opened those two translations in ATE and redelivered them

There is a known bug with having default permalinks and ATE not saving, but for SEO and other purposes, I don't recommend using default permalinks anyway.

Regards,
Bruno Kos

May 13, 2019 at 10:19 am #3796815

janettS

My issue is resolved now. Thank you!