This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The ACF fields are not displaying at the translation screen

Solution: - Go to the edit screen of the product

- Scroll down to Multilingual Content Setup

- Click on Show System Fields

- Se the system fields related to ACF as "Copy". These fields start with a underline on it (see screenshot).

- Click on "Apply"

- Scroll up, do a small modification on the page content and save

- Edit the translation, check the "Translation is complete" field and save

This topic contains 9 replies, has 2 voices.

Last updated by Diego Pereira 11 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 18, 2018 at 12:32 pm #2827922

gianlucaP-17

Tell us what you are trying to do?
I used ACF plugin for products. I just noticed that the custom fields are not manageable in other language.

Is there any documentation that you are following?
Yes. hidden link I looked into the link and didn't found option as mentioned

Is there a similar example that we can see?
No

What is the link to your site? hidden link

October 19, 2018 at 7:32 am #2830835

gianlucaP-17

I Installed the plugin Advanced Custom Fields Multilingual and now I am able to translate the fields. Now the issue is that I have a repeater field to add materials of product. The Repeater field is showing when I am translating product but the repeater data is not showing on the frontend i.e on the product detail page on other languages. I have made the setting of WPML > Custom Field Translation but the translated text is not showing up in other languages.

Can you guys please reply me soon as I have to make it work asap.

Thanks

October 19, 2018 at 7:39 am #2830865

gianlucaP-17

I have attached the screenshots for better understanding. Kindly look at it.

Thanks

October 19, 2018 at 7:21 pm #2832885

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @gianlucap-17, welcome to the WPML support Forum!

For the repeater fields, please try the steps available for this video: hidden link

Here is our guide on how to use ACF with WPML: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

If it does not work, please try to add the repeater fields on the translation using the mnaual editor:
- Go to the edit screen of the page (default language)
- Change the language using the language switcher at the top admin bar
- If it displays a warning, click on "Edit Anyway"

Please let me know if it worked for you.

All the best,
Diego

October 22, 2018 at 12:44 pm #2838061

gianlucaP-17

Hi

Thanks for responding back.

I already performed these steps but repeater field is not showing on frontend. As you can see in the screenshots i attached above, there is option to translate the fields but they are not coming on frontend.

For the manual editor option, I tried to do with this but when i am selecting Italian language for translating product it takes me to the woocommerce multilinguil page rather editing product in other language. See the attachment.

Also, today i faced an other issue of custom image type field. When translating to other language it shows me image id rather than its url but i selected to show image url while creating custom field. I have to manually paste the url of the image.

Please help on this as i have to make my site live in few days.

Thanks

October 22, 2018 at 6:26 pm #2839423

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In this case we need to reproduce the issue on a clean install to isolate it and run some tests. This is good because I can debug the issue without modifying the live website.

I created a test website with a clean WordPress install with WPML. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the ACF plugin to this test install and setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the ACF, the related functionality and some dummy content to reproduce the issue. You don't need to setup a entire website or clone your existing site.

May I kindly ask you please to open a new ticket for the new issue? we can investigate only 1 issue per ticket, since each requires a different process. This will also help other users with similar problems to find solutions when searching the forum.

Regards,
Diego

October 23, 2018 at 11:39 am #2842081

gianlucaP-17

I have created the same issue on your given link. I have created a product and assigned the custom fields to that product including the image field.

I don't have access to edit the files in your setup. So i am unable to code in the product detail file to show the custom fields.

Please check the fields in back end and show those fields on front end. Then you can see the issue i am facing.

The fields are showing in the English language but not in Italian. Please see screenshot below.
Also i have attached the second language screenshot where the repeater fields are not showing.

If you want then i can share my site access with you. Just share your email id here.

Thanks

October 23, 2018 at 3:06 pm #2843150

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, I added the PHP code from the ACF on the product page to display the custom fields:

                         <h1>Advanced custom fields here</h1><hr/>

			<div><b>Material Label: </b><?php the_field('material_label'); ?></div><br/><br/>

			<div><b>Repeater fields: </b><?php 
				if( have_rows('material') ):

					while ( have_rows('material') ) : the_row();

						// Your loop code
						the_sub_field('material_name');
				
						echo '<br/>';
				
						the_sub_field('material_description');

					endwhile;

				endif;				
				?></div>

            <div><b>Banner Bottom: </b><?php the_field('banner_bottom'); ?></div>

After that I was able to see the issue. The repeater fields are not displayed on the translation.

I was able to fix this using the steps below:
- Go to the edit screen of the product
- Scroll down to Multilingual Content Setup
- Click on Show System Fields
- Se the system fields related to ACF as "Copy". These fields start with a underline on it (see screenshot).
- Click on "Apply"
- Scroll up, do a small modification on the page content and save
- Edit the translation, check the "Translation is complete" field and save

Now the repeater fields are displayed correctly on both languages:
- hidden link
- hidden link

Please let me know if it worked for you.

Regards,
Diego

October 24, 2018 at 5:58 am #2845005

gianlucaP-17

Hi,

The issue is fixed and now the repeater fields are showing on the frontend in other language.

Thanks 🙂

October 24, 2018 at 12:36 pm #2846228

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I'm glad that the issue is resolved 🙂 Feel free to send us a message if you need more help.

Cheers,
Diego