This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.63 hours from now. Thank you for your understanding.

This topic contains 21 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 2, 2018 at 6:16 am #2780425

ridwanA

WPML Issue

After activated the plugin, some of the posts categories URL is broken.
Example
Before is working, the URL is
xxx.com/category/<category name>

After activate the plugin, 
The URL changes to
xxx.com/?cat_ID=<some numeber>
And this links to 404

Also, the Previous Entries and Next Entries button links are broken as well. It won't lead to previous or next entries.

Attach is the screenshot where I found weird
trying to investigate the issue my own, I doubt something to do with the categories.

I went to WPL > Translation of Categories > Term translation

One of the categories is always showing uncategorized no matter what I change and click save it auto become uncategorized again.

October 2, 2018 at 8:29 am #2780670

ridwanA

Forgot to attach the screenshot.
Here the screenshot no matter what text I put, after I click "Save" it become uncategorized again

October 3, 2018 at 3:27 pm #2785083

ridwanA

It's been 1 day and 9 hours

And they're not a single reply? Where the support? It breaks my site and there no support at all. Though is a paid plugin and is recommend by elegant theme.

How long will it take for you guys to make support? Response please!

October 4, 2018 at 4:23 am #2786414

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Sorry for the delay in replying as the forum is loaded. I will try my best to solve this issue as soon as possible.

Just activating WPML plugins will not affect in the change of your permalink structure, could you please go to settings -> permalinks and save the permalinks once, does this help?

Further, It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

October 4, 2018 at 7:00 am #2786514

ridwanA

I can't...just inactivate all the plugin, there quite some plugin and will affect the site heavily
however the debug.log show this

[04-Oct-2018 06:51:50 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 34
[04-Oct-2018 06:51:50 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 36
[04-Oct-2018 06:51:56 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 34
[04-Oct-2018 06:51:56 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 36
[04-Oct-2018 06:52:02 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 34
[04-Oct-2018 06:52:02 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 36
[04-Oct-2018 06:52:38 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/hellogol/public_html/wp-includes/functions.php on line 4037
[04-Oct-2018 06:52:38 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 34
[04-Oct-2018 06:52:38 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 36
[04-Oct-2018 06:52:39 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 34
[04-Oct-2018 06:52:39 UTC] PHP Notice: Trying to get property of non-object in /home/hellogol/public_html/wp-content/plugins/wp-post-navigation/wp-post-navigation.php on line 36

also when I went to the dashboard this error popout

October 4, 2018 at 11:21 am #2787310

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can just dismiss the message.

Regarding the issue, to further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

October 4, 2018 at 4:27 pm #2788203

ridwanA

Have shared the information

I actually try in a staging environment before I update this plugin to the production.
but in the staging environment, WPML didn't break anything. but once move to production those permalink is broken, I have also try to save the permalink like the way you mention but is not working 🙁

October 5, 2018 at 8:34 am #2789861

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Before the login details, you have an HTTP authentication, could you also provide me with those details.

You can edit your previous private reply.

Thanks

October 5, 2018 at 3:54 pm #2791238

ridwanA

Hi Shekhar,

Have reply from the previous private reply.
Do let me know how I can make thing faster for you.
Thanks

October 8, 2018 at 4:33 am #2794751

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The login details are still not working. Could you please check it once.

Further, since you mentioned duplicator isn't working properly, could you please please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Look forward to your reply.

Thanks

October 8, 2018 at 11:16 am #2795755

ridwanA

As in username and password is not correct or the http issue?

I have used this plugin to export out all the information you needed. I think it works just like the duplicator.
https://wordpress.org/plugins/all-in-one-wp-migration/
Have put it in the google drive I share you previously.
And about the wp-content I am sorry is hard to provide me, as the server not controlled by me, there always a timeout issue when I download a certain amount of files.

Anyhow, we can process this faster? like having a live chat or anything?

Let me know please would love to move this issue quickly. For the login issue please let me know what the issue.

Also in the current site, I have to disable WPML for now as is breaking lot of permalink in blog and is gettting lots of complaint from the users.

October 8, 2018 at 11:25 am #2795794

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, the login details itself is not working.

I am sorry to let you know that currently, we don't have any live chat support.

And about the wp-content I am sorry is hard to provide me, as the server not controlled by me, there always a timeout issue when I download a certain amount of files.

Without the wp-content it will be hard to resolve the issue, can't you use your hosting service panel and create a backup without the wp-uploads folder. Usually creating backups from hosting service panel is fast.

Look forward to your reply.

Thanks

October 9, 2018 at 12:47 am #2797620

ridwanA

Hi Shekhar,
For the wp-content, I will try to get the access from the company itself.
And for the login access, I have updated the password, try it and is working.

The database files are in the previous google drive link?

Let me know if you able to login

October 9, 2018 at 2:04 am #2797666

ridwanA

Have added wp-content in the google drive

October 9, 2018 at 8:24 am #2798875

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I activated the WPML plugin on your site and updated the permalinks once and I can see that the categories are working properly, could you please check the issue once more?

The category I tested was: hidden link

Look forward to your reply.

Thanks

The topic ‘[Closed] After activate the plugin, some of the categories in posts is broken’ is closed to new replies.