Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Laura 1 month, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
November 19, 2019 at 9:46 am #4970293

alexanderA

Hello. I am having an issue with alt text. It is related to this issue I previously opened (https://wpml.org/forums/topic/how-to-translate-image-alt-text/). Here are the steps I take, and the issue I encounter:

* Set WPML language in admin bar to default language: English.
* Upload an image to WordPress.
* In media library, add EN alt text to image.
* In admin bar, change WPML language to Chinese (CN).
* In media library, add CN alt text to the same image.
* Re-load media library to confirm CN alt text is saved (see attached screenshot hh-alt-1).
* Create new EN language post.
* Insert my new image into post. This can be either a body image or a featured image.
* Save post.
* Duplicate post into CN via WPML-->String Translation. In the process, the String Translation asks me if I want to duplicate the media attached to this post. I do so, by ticking box next to all images in the post. I hope you know what I'm describing here. If not, I can send screenshots.
* After duplication, ensure WPML language in language bar is set to CN, and open media library. Alt text on the image has reverted back to the EN alt text (see attached screenshot hh-alt-2).

I am then forced to re-add the CN alt text to each image, AND re-add each image to the newly duplicated CN page. This is a bit tedious and annoying. Why is it occurring and how can I ensure it does not occur?

Thanks.

November 21, 2019 at 12:37 pm #4987947

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for contacting us.

Could you reproduce this behavior here? hidden link

So I can check with the developers if we can do something about it.

November 24, 2019 at 4:42 am #5005853

alexanderA

Give me a few more days and I'll reply to this.

November 24, 2019 at 4:52 am #5005857

alexanderA

To reproduce the behavior, I need WPML-->Translation Management installed on that sandbox site. How can I do that?

Also, in the step-by-step instructions I posted a few days ago, I incorrectly referenced 'String Translation.' I meant to type 'Translation Management.'

November 24, 2019 at 8:57 am #5006063

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

Translation Management is already installed on the Sandbox, you only need to activate it from the Plugin page.

November 24, 2019 at 9:44 am #5006159

alexanderA

OK got it, thanks. I was able to activate it, then carry out the same steps. Once I did so, the same issue occurred. Are you able to do the same?

November 24, 2019 at 10:38 am #5006321

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I could see the issue in the Sandbox.

I noticed that if you duplicate from the page itself and not from Translation Management the issue doesn't happen (check the Media Library in French).

When you duplicate a page, and in this case media, all the previous content on the page is overwritten. So if you duplicate the media, Alt text, caption, etc are overwritten in the Media file.

If you duplicate the page via Translation Management without selecting the media, you still have the image in the duplicate page (check hidden link this one was duplicated via Translation Management) but the French media file still has its correct Alt content in the Media Library.

Please also notice that in this page I just linked the image has English Alt text. This is expected, because when you duplicate a page, ALL the content must be identical to the original one, including Media caption, Alt texts, etc. It's not possible to duplicate the page content and use Media files from another language, you need to manually change them.

Let me know if this helps you or if you need further assistance.

November 25, 2019 at 11:28 am #5011497

alexanderA

>> It's not possible to duplicate the page content and use Media files from another language, you need to manually change them.

OK got it. So perhaps the most efficient course of action should be to add the alt text to images *after* I've duplicated the pages. That way I don't have to add the alt text twice.
Would you agree?

November 25, 2019 at 11:29 am #5011503

alexanderA

Or maybe an alternative is to add the EN and FR alt text as soon as I upload the image. Then, when I duplicate the post, ensure to *not* duplicate the media. What about that option?

November 25, 2019 at 11:40 am #5011573

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

if you change the Alt text to the duplicated images, you are editing the English image, not the Chinese one, so I'm not sure it will not reflect on the English image. You should try this out first.

November 27, 2019 at 5:25 am #5025939

alexanderA

I'm not sure what you mean by that--can you clarify? Or maybe just let me know which of these two approaches would be more efficient:

1. Add the alt text to images *after* I've duplicated the pages. That way I don't have to add the alt text twice.

2. Add the EN and FR alt text as soon as I upload the image. Then, when I duplicate the post, ensure to *not* duplicate the media.

Thanks.

November 27, 2019 at 2:08 pm #5029915

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

both solutions should be working - I checked them in the Sandbox and got the same result, so you can choose the one that's more convenient for you.