This thread is resolved. Here is a description of the problem and solution.

Problem:After an update "New Translations are available" my website crashed.

Solution:Please make sure that you have the latest versions of WPML and its add-ons

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by daniC 2 years, 11 months ago.

Assigned support staff: Bobby.

Author Posts
April 10, 2017 at 6:43 pm #1251496

daniC

This morning I updated my WPML "new translations are available", after I finished the update my website crashed. I then went through every plugin and deactivated each one to see if it was truly the update that crashed the site. Once the WPML plugin was deactivated the website went back online.

Hope you guys can help me out soon, as the client is waiting for his website to go back online.

Thanks,
Jeff

April 10, 2017 at 7:06 pm #1251507

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I would need to see the detail of the error. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

April 11, 2017 at 7:20 pm #1252434

daniC

[21-Dec-2016 01:58:24 America/Denver] PHP Warning: include(hosting_provider_filters.php): failed to open stream: No such file or directory in

April 11, 2017 at 8:38 pm #1252466

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you !

I removed the information from above as it is not relevant and for privacy reasons.

The errors logged were from 21 December 2016 and not related to WPML.

Please go to wp-config.php and let me know what is your current WP_Memory_Limit

https://wpml.org/home/minimum-requirements/

=>To see the WP memory limit you have to login using your FTP and going into the
wp-config.php file , and it will be at the very top.
The Documentation i attached for you goes over details the requirements.

What are your results now if you activate WPML ?

Also please try to activate it in a minimal enviroment

-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

Kind Regards,
Bobby

April 13, 2017 at 6:10 pm #1254029

daniC

I got the WP_MEMORY_LIMIT which is between 40M to 64M. I also created a phpinfo.php file, so if you need more information you can visit hidden link , don't know if it will help.

As soon as I active the WPML plugin my site crashes, with my current theme (The7).

I also deactivated all my plugins except for WPML, and changed theme (Twenty Sixteen). The result was the same even with the new theme. The site was down, but as soon as I deactivated WPML, the website went back online.

thanks,
Jeff

April 13, 2017 at 8:49 pm #1254086

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you !

Please add to your wp-config.php file

define( 'WP_MAX_MEMORY_LIMIT', '256M' );
define( 'WP_MEMORY_LIMIT', '256M' );

Our minimum requirement is 128M but please try the above.

Also contact your host and ask them to increase the memory from their side too if possible.

April 13, 2017 at 9:30 pm #1254096

daniC

Hi,

Unfortunately, Bobby I did exactly as you suggested and did the following changes
define( 'WP_MAX_MEMORY_LIMIT', '256M' );
define( 'WP_MEMORY_LIMIT', '256M' );
and i also contacted my host and asked them to increase the memory to 256M on their end, which they did. But the site is still not working when the WPML plugin is active.

Thanks,

Jeff

April 14, 2017 at 1:27 am #1254142

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Jeff,

All you did was just to run the update from within Theme and plugins localization and after that the plugin has been crashing correct ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

April 14, 2017 at 5:32 pm #1254583

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Jeff,

Please verify the Access details as i currently cant log in to your site's wp-admin

I have re enabled the private field

Thank you !

April 18, 2017 at 7:06 pm #1256425

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

These access details are not working for me either , please view screenshot. (you should be able to edit the previous private reply)

We have released a new WPML version , if possible do delete your current version and test the new version we have by installing it manually.

to do a manual update please follow these steps:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

=>https://wpml.org/home/minimum-requirements/

April 27, 2017 at 4:52 pm #1263640

daniC

There was an update for WPML plugin and that seemed to fix the problem.
Thanks!