This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by Bruno 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
June 19, 2018 at 9:39 pm

Jakub Fajfer

I am trying to: translate page

Link to a page where the issue can be seen: mazuryairshow.pl > mazuryairshow.pl/en (In fact You can see problem only in backend)

I expected to see: every element existing still separately

Instead, I got: on transslated page all following elements included in HTML code

Secondly on translated page element Fancy Text loose it format (no more </br>)

June 20, 2018 at 9:59 pm #2425748

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

I would be very happy to help you but I didn't fully understand what is the issue. When I access both the homepage on the front end and the back end, it looks like it's working correctly.

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

June 20, 2018 at 10:18 pm #2425772

Jakub Fajfer

Of course, I am sorry.

pic#1 "WPML backend oryg" - this is backend in oryginal language. You can see a lot of elements (there is more than on this screen), even behind "Kod HTML"
pic#2 "WPML backend translated" - elemnts ends up with "Kod HTML". All other elements are packed/included in "Kod HTML". You can better see it in "Classic Mode"

Secondly - element Fancy Text (phrases scrolling up one by one) when translated it loose "next line code". "Next line" is needed to separate scrolling phrases. Compare this text (just under slider) on
mazuryairshow.pl and mazuryairshow.pl/en

June 21, 2018 at 12:41 pm #2427058

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the detailed explanation. Now I've been able to see both of the issues you're reporting.

About the first issue, this seems strange. It looks like this is correct in the "Classic Editor", but in the "Backend Editor" I can see the problem. Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

About the second problem, unlike the default language of one line per string, the "Fancy Text" in English is all on the same line. I'll attach an image for you to see.

I'm not sure how you translated this content, but changing and adding the terms per line in the English language, the same way it's in Polish, does it work?

Thank you.

June 21, 2018 at 2:04 pm #2427233

Jakub Fajfer

Bruno, be my guest, Duplicator is already installed, need to be activated.

Regarding to second issue - translating directly in the backend editor do work. But using WPML editor do not. Moreover, when once You translate it correctly in backend editor (as on Your pictures), when next time You translate anything on that page in WPML editor, it result in loosing end of line characters in that Fancy Text field.
And in WPML editor, You can not use "enter" nor "shift enter". It result in popup "Copy all fields from oryginal"

June 22, 2018 at 3:11 am #2428394

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I did a copy of your site. I will install it on my test environment and soon I will contact you.

Thank you.

June 23, 2018 at 3:34 am #2430396

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. About the "Fancy Text", this seems to be a compatibility issue with "Ultimate Addons" plugin. When you create this in the original language, you can make a list (one item per line), while in translation, these texts are on the same line.

About the problem you reported initially, apparently, this HTML code has been corrupted. You should go to the "Classic Editor" and remove the contents of the "raw html" in the secondary language. That is, you need to remove this "encrypted code". I'll attach an image for you to see.

After following these steps, you can switch back to the Visual Composer editor. Note that "Raw HTML" will be empty. That way, you should enter the desired HTML code again.

To ensure that this plugin is made compatible with WPML we need to contact the plugin author and work with him on resolving the issue.

I have forwarded the details to our Themes & Plugins Compatibility Team and they will contact the author. Our Compatibility Team will work with the author of the plugin for this to work properly.

Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

Thank you.

June 25, 2018 at 2:59 pm #2433068

Jakub Fajfer

It works, thank You.

July 5, 2018 at 3:13 pm #2468032

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Our compatibility team fixed the Fancy Text problem. As a workaround, please follow the steps below:

- Add this to WPML -> Settings -> Custom XML configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>ultimate_fancytext</tag>
            <attributes>
                <attribute encoding="allow_html_tags">fancytext_prefix</attribute>
                <attribute encoding="allow_html_tags">fancytext_suffix</attribute>
                <attribute encoding="allow_html_tags">fancytext_strings</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

- Go to Ultimate_VC_Addons/modules/ultimate_fancy_text.php on line 530 and replace:

$order   = array("\r\n", "\n", "\r", "<br/>", "<br>");

with:

$order   = array("\r\n", "\n", "\r", "<br/>", "<br>", "<br />");

- Go to the Translation Editor and save the page

Note that you must use the "<br />" delimiter so that the strings are displayed correctly. For example, if in the "Fancy Text" editor you used one string per line:

Text
Example

In the Translation Editor you should add, for example:

Text<br />Example

That way the strings will be displayed on the front-end.

Our compatibility team will contact the plugin's author to suggest this change in code.

Thank you.

July 7, 2018 at 9:58 pm #2472957

Jakub Fajfer

It works but only partially. On original language after each element there is now addtional blank line. Each element dissapear for a while. Look at this page:
hidden link

July 16, 2018 at 11:27 pm #2528851

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry, I had not seen your previous message. This seems to be happening because you have altered the effect of "Fancy Text" to "Slide Up". I reported this to our compatibility team. Soon we will contact you.

Thank you.

January 9, 2019 at 10:41 am #3070811

Jakub Fajfer

Hi,

any progress in that area? Unfortunatelly on my page Fancy Text when translated is still not working correctly. And even during translation there is still no possibility to make many lines of text (separately displayed).

best regards
Jakub

January 9, 2019 at 12:11 pm #3071413

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

According to our compatibility team, the author said he would fix this in future versions.

Are you using the latest version of "Ultimate Addon"? Have you contacted the plugin author to see if this is already fixed or will it be fixed in another version?

Thank you.

January 9, 2019 at 12:24 pm #3071473

Jakub Fajfer

Hi,

I am using latest version (3.17.1).
I was not contacted UA author, I thought that You cooperate closely. Moreover, he promise it to You in Your conversation, so I do not have much to relate to in correspondence with him.
Is it possible that You follow up Your arrangements?

brgrds

January 9, 2019 at 12:30 pm #3071504

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. I will contact our compatibility team again so they can check. Soon we will contact you.

Thank you.