This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Laura 1 year, 4 months ago.

Assigned support staff: Laura.

Author Posts
May 9, 2018 at 2:36 pm #2054458

kayM-2

Tell us what you are trying to do?
After I activate WPML, My site design got messed.

Is there any documentation that you are following?
No.

Is there a similar example that we can see?
No.

What is the link to your site?
hidden link

I have attached both Screen shots, with and without WPML

May 9, 2018 at 2:38 pm #2054643

kayM-2

Yes, I still need help urgently please.

May 9, 2018 at 3:13 pm #2055781

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I will need more information to help you, so please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, please check if your site meets our minimum requirements, in particular, WP Memory limits. You can find more about them here: https://wpml.org/home/minimum-requirements/

There is the chance that yours is a theme compatibility issue, so you may want to check if your theme is compatible with WPML. You can search for it here: https://wpml.org/documentation/theme-compatibility/

May 9, 2018 at 3:47 pm #2057011

kayM-2

[09-May-2018 15:41:05 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:41:05 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:41:13 UTC] PHP Notice: wpdb::prepare wurde fehlerhaft aufgerufen. Die Abfrage enthält nicht die korrekte Anzahl von Platzhaltern (2) für die Anzahl der übergebenen Argumente (3). Weitere Informationen: <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress (engl.)</a> (Diese Meldung wurde in Version 4.8.3 hinzugefügt.) in /homepages/37/d706870026/htdocs/letssharedreams/wp-includes/functions.php on line 4147
[09-May-2018 15:41:14 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:41:15 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:42:14 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:42:14 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:42:27 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:42:27 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:43:13 UTC] PHP Notice: wpdb::prepare wurde fehlerhaft aufgerufen. Die Abfrage enthält nicht die korrekte Anzahl von Platzhaltern (2) für die Anzahl der übergebenen Argumente (3). Weitere Informationen: <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress (engl.)</a> (Diese Meldung wurde in Version 4.8.3 hinzugefügt.) in /homepages/37/d706870026/htdocs/letssharedreams/wp-includes/functions.php on line 4147
[09-May-2018 15:44:02 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:44:02 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:44:19 UTC] PHP Notice: wpdb::prepare wurde fehlerhaft aufgerufen. Die Abfrage enthält nicht die korrekte Anzahl von Platzhaltern (2) für die Anzahl der übergebenen Argumente (3). Weitere Informationen: <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress (engl.)</a> (Diese Meldung wurde in Version 4.8.3 hinzugefügt.) in /homepages/37/d706870026/htdocs/letssharedreams/wp-includes/functions.php on line 4147
[09-May-2018 15:44:23 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.
[09-May-2018 15:44:23 UTC] We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.

May 10, 2018 at 10:45 am #2069764

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

this can be a theme configuration issue. Avada theme supports different options depending on the language, and you need to configure them. For security reason, I suggest you create a backup of your site before proceeding.

- Go to Avada -> Theme Options -> Import/Export
- Select your default language using the language switcher in the upper admin bar
- Click on "Download Data file" to create a security backup file
- Click on "Copy Data"
- Copy the text (CTRL+C on Windows/Linux or CMD+C on Mac)
- Switch to your second language
- Paste your previously copied text in the box (CTRL+V on Windows/Linux or CMD+V on Mac)
- Click on "Import"
- Wait for the importation to finish
- Check if everything was imported correctly

You can read more about language configuration here: hidden link

You can also read our documentation here: https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/

Let me know if this resolves the issue or if you need more help.

May 28, 2018 at 5:54 pm #2240924

kayM-2

Hello Laura,

This is still not resolved. Nothing works, I am still facing same issue. Please help me.

Kay

May 29, 2018 at 7:13 am #2243160

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

this thread is marked as resolved, please open a new one. Thanks.