This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.24 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 5 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
March 30, 2019 at 1:41 am

chenbiaoZ

I am trying to:

Link to a page where the issue can be seen: hidden link

Its AMP page used to be: hidden link

Actually, ALL of our blog posts' AMP page is invalid.

Our theme is Soledad theme, which integrates with AMP.

I expected to see: All of our AMP page valid again.

Instead, I got:

March 31, 2019 at 8:16 pm #3502599

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

The Soledad theme and the PenCi Soledad AMP - WordPress Complete AMP plugin are not in our compatible lists of themes and plugins, and it might be a compatibility issue.
https://wpml.org/documentation/theme-compatibility/
https://wpml.org/documentation/plugins-compatibility/

But before we continue to check if it is a compatibility issue, we need to find out that problem is not caused by the following. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Please also update WordPress itself to its latest version.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

April 2, 2019 at 3:40 pm #3518881

chenbiaoZ

Hi Itamar,

Thank you for your detailed information. We finish the settings as you said but the AMP seems still invalid.

Could you please kindly check it? As for the debug information, maybe you can login our WP and get it from WPML plugin.

Thank you!

Best,

Z

April 3, 2019 at 1:36 pm #3526629

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Z and thanks for following my suggestions.

Please continue with the following debugging procedures.

1. Update all the related components that are involved in this issue.

A. Update WordPress to its latest version (currently 5.1.1 and you are using 4.9.10) and see if the issue persists.

B. We have just released new versions for WPML and its add-ons, so please also update WPML at this opportunity. Check if the issue persists.

C. Update your theme the Soledad theme. It is on version 5.2, and version 6.3.1 is available. While you are updating the theme please also check if the PenCi Soledad AMP add-on of the theme has a new version.

2. If the issue persists after that everything is updated, then I suspect that there is a collision with other plugins. If possible get your site into a minimum environment. Minimum environment, in this case, means deactivating all the third party plugins and leaving active only WPML and its add-ons and the PenCi Soledad AMP plugin. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

April 3, 2019 at 4:17 pm #3528539

chenbiaoZ

Hi Itamar,

I try to upgrade WPML after update wordpress, but it shows error as shown in the screenshot. Please kindly check it. thanks

April 4, 2019 at 5:56 pm #3537533

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When I go here hidden link and try to update, I can see the following message.

Your subscription appears to no longer be valid. Please try to register again using a valid site key.

Please register your site with a valid site key.
See the following documentation on how to register a site.
https://wpml.org/faq/install-wpml/

Regards,
Itamar.

The topic ‘[Closed] After install WMPL, our AMP is disappeared and this leads to traffic decrease’ is closed to new replies.