This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by igorL-11 11 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
October 16, 2018 at 3:40 am

igorL-11

I am trying to: resolve the 500 error and make my site work again

Link to a page where the issue can be seen: travelcalypso.ru

I expected to see: I was using Panagea theme and it went white 500 error screen completely after installing WPML. Then theme developer asked me to change theme to some other like twenty fifteen. I activated twenty fifteen theme and site start working but admin panel still gives me fatal error on many pages including WPML admin. Developer suggested to contact you because WPML is not working even on WP default theme.

Instead, I got:

October 16, 2018 at 5:56 am #2819796

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

Plugin conflict
Could you please disable all the plugins and check this?
Sometimes jetpack may cause this.
Anyhow, please disable all non-wpml related plugins and check.

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know if you still have the issue after you followed the above steps.
We will check your duplicator.

Regards,
Riffaz.

October 16, 2018 at 3:24 pm #2821549

igorL-11

Hello Riffaz,
You were right it was a jetpack plugin, I disabled it and site started to work. Now how do I make the jetpack to work?
Thanks

October 17, 2018 at 3:32 am #2823094

igorL-11

I also get this message in my setup:

One more step before you can translate Visual Composer
You need to enable WPML's Translation Editor, to translate conveniently.

This action is not allowed

Can't enable WPML's Translation Editor, how to avoid this error?

October 17, 2018 at 4:49 am #2823133

igorL-11

I tried to translate home page into russian but after clicking on russian flag I still get white screen error page. Also I checked one youtube tutorial, the translation process looks like (please see the screenshot attasched) where you have 2 versions of pages and see percentage of completion as you progress. I don't get this layout.

October 17, 2018 at 4:52 am #2823134

igorL-11

Screenshot

October 17, 2018 at 5:22 am #2823161

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Igor,

That's great. you've found the cause now.

Follow these steps:
1. disable WPML and it's addons
2. enable the jetpack

You will see that your site will stop working.
So you can understand that this does not come from WPML.

Very likely it's between your hosting, theme and JetPack.
Please discuss this with their supports.

In WPML support, we strictly answer one question only in a single ticket to avoid the confusion and for better references in future.

So please open new dedicated for your every new question.
The initial question of this ticket is about 500 error which has been resolved.

Please open new tickets for the other questions. we are happy to help.

Regards,

October 17, 2018 at 7:29 am #2823516

igorL-11

Doesn't make sense. My site was working fine with Jetpack active untill I installed and activated WPML. So how can you say that error not come from WPML?
I have just desabled WPML and all adons and activated Jetpack as you said, and my site is working fine. But as soon as I activate WPML I am sure I will get 500 error again.

October 17, 2018 at 11:02 am #2824261

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Igor,

Then it's really strange.

Please perform these steps:

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Ps:
I could not duplicate your site in my localhostsince your duplicator package has SQL files only.
We will need a complete duplicator in order to duplicate your site in our local host

Regards,

October 17, 2018 at 12:57 pm #2824640

igorL-11

When I follow debugging information you provided I get a error message instead of just blank white screen (please see screenshot). I tried to increase the WP memory but it did nit work.
Jetpack is not the only problem apparently. I translated home page into russian and when try to open it get white 500 error screen, even when jetpack is inactive.
Below is the debug.log content as you requested:

[14-Oct-2018 06:27:03 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 786432 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/jetpack/locales.php on line 2149
[14-Oct-2018 06:27:12 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 3072 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php on line 348
[14-Oct-2018 06:27:20 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 786432 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/jetpack/locales.php on line 2149
[14-Oct-2018 06:28:00 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 786432 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/jetpack/locales.php on line 2149
[14-Oct-2018 06:37:47 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 786432 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/jetpack/locales.php on line 2149
[14-Oct-2018 06:37:56 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 12288 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/panagea-booking/inc/shortcodes/templates/slider-image.php on line 93
[14-Oct-2018 06:38:00 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 248 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/panagea-booking/inc/shortcodes/templates/slider-image.php on line 113
[14-Oct-2018 06:38:01 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4480 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/panagea-booking/inc/shortcodes/templates/slider-image.php on line 104
[17-Oct-2018 12:49:11 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 187804 bytes) in /home/igorlavres/domains/travelcalypso.ru/public_html/wp-content/plugins/redux-framework/ReduxCore/inc/fields/typography/googlefonts.php on line 1

October 17, 2018 at 1:15 pm #2824708

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

hi Igor,

You've found the real cause finally.
Please show this error message to your hosting company.
They will fix it within minutes.

Regards,

October 29, 2018 at 2:20 pm #2858355

igorL-11

My issue is resolved now. Thank you!