This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Lauren 3 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
June 15, 2019 at 6:45 am

williamH-20

I am trying to: I changed a picture in the default language and trying to copy the picture to the other languages

Link to a page where the issue can be seen: hidden link (home page)

I expected to see: the same picture used for the other languages

Instead, I got: Different pictures

June 15, 2019 at 6:46 am #4025699

williamH-20

Sorry I was unable to install duplicator: "The uploaded file exceeds the upload_max_filesize directive in php.ini."

June 15, 2019 at 4:45 pm #4028479

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

At this stage Duplicator isn't needed, I'll give you another option if I ever need a copy of your site.

I tried to check your homepage to see the issue but I get a connection timed out error. Could you check it? Could you also give me some more details about your problem, perhaps adding some screenshot? Thank you.

June 15, 2019 at 8:18 pm #4028863

williamH-20

Sorry about that. I got an autogenerated message from WPL that it'll be Monday before someone looked into this so I powered off the server to reduce my carbon footprint :o. It's back up now and I will not shut it down.

June 15, 2019 at 8:26 pm #4028865

williamH-20

In the sample below I show the English page and the Chinese page. I tried using the WPM->Setting->Media Translation Documentation ->Start to move the picture and it didn't work. I also edited the Chinese page and manually changed the link to the correct png file but even after I saved the page it reverted back to the incorrect image. 🙁

June 15, 2019 at 8:27 pm #4028911

williamH-20

Thanks

June 17, 2019 at 6:08 am #4032295

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I still can't access the server, but in the meantime here a few things you can try:

1. The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Once you did this, try replacing the images again and see if it works.

2. After increasing the WP Memory Limit, try clearing the cache in WPML going to:
WPML -> Support -> "troubleshooting" link -> "Clear the WPML cache" button
Please do a backup go to WPML -> Support -> troubleshooting -> clear the cache in WPML button

3. If you still don't get results, please do a compatibility test:
- backup your site
- disable all plugin except WPML and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

June 19, 2019 at 3:55 pm #4053097

williamH-20

I tried #1

 
/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

and #2 (WPML->support->troubleshooting->clear WPML Cache

ANd I'm still getting the same issue. I'm going to do step #3 (compatbility check) but I think that's a drastic change (it's like starting all over agian .... )

June 19, 2019 at 5:50 pm #4053673

williamH-20

Are there any known compatibility issues with Storefront?

June 19, 2019 at 8:53 pm #4054651

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Laura is off so I'm stepping in to help out. I hope that's okay. I tried to access your site to troubleshoot but the credentials in your original post are not working for me. Please double check and update as needed. I have marked the next reply as private.

June 20, 2019 at 2:20 pm
June 20, 2019 at 3:35 pm #4061035

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, this time I was able to access the site. Then, I'd like to have you try a few things so we can try to isolate the issue. This is best to test on a staging site if you have one, and this is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

June 20, 2019 at 11:32 pm #4063571

williamH-20

OK. Just one question before start doing that ....

I noticed that WPML --> Media Translation takes you to a table that lists all the media available for translation, with options to translate title, caption and descriptor. THe image in the front page (that I'm concerned about) is not listed in that page. Is that significant?

June 21, 2019 at 2:35 pm #4067831

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

That page should show all media files that you have uploaded. Does the image show when you go to Media Library in all languages?

The topic ‘[Closed] After Media Translation pictures are not copied to other languages’ is closed to new replies.