This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Language Switcher style.css file do not load because of the following message in the console. Mixed Content: The page at 'https://yourdomain.com/' was loaded over HTTPS, but requested an insecure stylesheet. This request has been blocked. Solution: If you are using HTTPS for your site then make sure in WordPress Settings -> General that WordPress Address (URL) and Site Address (URL) are set to HTTPS.

This topic contains 4 replies, has 3 voices.

Last updated by benjaminM-26 2 years, 9 months ago.

Assigned support staff: Itamar.

Author Posts
January 10, 2017 at 11:49 pm #1179042

Savannah Michalah Kofoed

Hello WPML!

I am trying to: I was releasing my clients new website, so I have copied the database to a new name and the files to a new folder (and also setting correct domain settings). I used Better Search Replace to make sure all remnents of the old domain was changed to the new one. I now have the original dev site on hidden link and the new site on hidden link . On the test site, I had setup the language switcher, both widget in header and footer switcher, to a horizontal style using the WPML Languages page. It looks great. But after the move to omahara.com, the style is lost, somehow. The colors are lost and they are vertical of each other. They have become ordinary vertical bullet items. Also, the footer is left aligned instead of center aligned. The same styling problems is on the WPML Languages page where I setup both the widget switcher and the footer switcher. I'm using Vantage theme from SiteOrigin.

URL of (my) website where problem appears: hidden link (top widget and footer)

I expected to see: Same styling as on my testing site.

Instead, I got: Vertical, non-styled languages.

Steps to duplicate the issue: I'm not sure, it happened after I moved the site. See steps above.

I'll create a user in wordpress to check the internals if you like, just tell me an email to create a user for.

The old site, omaharatest.com is not real, you need to setup the ip in the hosts file (for Windows): 77.66.117.58 omaharatest.com

Screenshot of how it looked (correctly) on omaharatest.com:
Header - hidden link
Footer - hidden link
Screenshot of how it looks now on the new site, omahara.com:
Heder - hidden link
Footer - hidden link (left-aligned)

If there is anything more I can tell you, please say so 🙂
Thank you for (an) awesome plugin(s)

January 11, 2017 at 9:47 am #1179289

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello.

Thank you for contacting the WPML support forum.

I've checked your site with the developer's tool of my browser.
It looks that for some reason your site is missing the style.css file in this path.
/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-list-horizontal/style.css?ver=1
Can you, please check with FTP/File Manager this location and see if you can see the style.css file in this location?
This is what you should see in this folder.
Please see attached screenshot legacy-list-horizontal-content.jpg

I look forward to your reply!

Thanks,
Itamar.

January 11, 2017 at 10:47 am #1179379

Savannah Michalah Kofoed

Ehm, this might be the problem, I guess? (see attached screenshot of the Console from Chrome). The page is running with SSL (created automatically by CPanel somehow. Pretty magic, I don't know much about it) - but it seems WPML were unaware of it?

Edit: (I wrote the above a few hours ago but was disturbed on work, so never got to send it. I found out that the Site-url and Home options was set to http. Change to https didn't fix it right away, but if you havn't changed anything, it might have been a cache problem afterwards. My guess is that the problem was http->https. It seems to work now, great!

Thank you for really really awesome support!

January 11, 2017 at 11:00 am #1179398

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

You're Welcome!

I guess that in this case I just gave you the direction, but you pinpoint the problem 🙂

I wish you good luck with your web project.
Itamar.

October 24, 2018 at 9:58 pm #2847936

benjaminM-26

Just want to bump this solution that worked for me October, 2018...

https://wpml.org/forums/topic/https-error-with-templateslanguage-switcherslegacy-list-horizontalstyle-css/#post-1272555

I found about 20 different examples of people reporting similar issues. I went down the rabbit hole of serialized arrays in the DB, and all sorts of rabbit holes. This needs to be marked as a solution and referenced on the rest of the support threads with this issue.

1) Check the home and site URLs to make sure they are set to https://
2) De-activate and re-activate the plugin

I had already done an extensive search and replace and cleared all caches on my particular instance.