Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by rolandS-21 2 years, 2 months ago.

Assigned support staff: Laura.

Author Posts
December 29, 2018 at 8:07 am #3041812

rolandS-21

Tell us what you are trying to do?

Is there any documentation that you are following?
If i make a payment in my current language (Estonia), it redirects back to estonian page and sends email in estonian. But if i make a payment in ENG lang, it redirects back to Estoninan page and sends email in estonian - but has to redirect to eng page, and to send email in english.
If you think that you can fix it, i can grant you access to my page.

Is there a similar example that we can see?

What is the link to your site?

December 29, 2018 at 9:26 am #3041845

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Waiting for updates.

December 29, 2018 at 9:40 am #3041853

rolandS-21

I need a few hours, i will write to you if i have completed.

December 29, 2018 at 10:28 am #3041863

rolandS-21

I have reproduced the issue.

So if I make the payment in Estonian language, it redirects back to hidden link
but the page is in english, it has to be in estonian, the email is also in english.

I think the e-mail is translated by default by wordpress. I didn't have time to translate the email, but if the redirection back to current language is working then should be the emails.

I added a test product, in checkout page you have to choose the delivery, and payment method should be SWEDBANK, you can make the payment, it is connected to a TEST environment and you dont have to pay for it.

December 30, 2018 at 2:51 pm #3043207

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

probably the plugin isn't multilingual ready.

However, I must have messed something because after I placed an order in Estonian I got correctly redirected here: hidden link
Maybe it's because I don't have an Estonian bank account and from what I understand Make Commerce is all about bank transfers.

Could you confirm the exact steps? If we need a bank account to reproduce the issue, could you make a video showing the whole process? In this way, the compatibility team would be able to see where to check the issue even if we cannot reproduce it.

January 5, 2019 at 10:40 am #3058866

rolandS-21

1. Add the product with name "TEST ESTONIAN"
2. In checkout choose SAADETIS -> Omniva pakiautomaat
3. In the dropdown "--vali pakiautomaat--" choose random.
4. Payment method click SWEDBANK
5. Click "Esita tellimus"
6. It will redirect you to a payment page. Click on the green button with text "SOORITA MAKSE".
7. It will redirect you to a another page. Click on the green button with text "Tagasi kaupmehe juurde".
8. After the payment in Estonian language, it redirects back to hidden link

Do not worry, you don't have to have an estonian bank account to make the payment, it is connected to a TEST environment, so you don't need account only click buttons.

January 5, 2019 at 12:22 pm #3058984

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the detailed explanation. I escalated the ticket to the compatibility team, I'll let you have news as soon as possible.

January 16, 2019 at 9:49 am #3096778

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the delay in replying. Unfortunately, the Sandbox has expired and I forgot to take a backup. I did recreate another one, but I can't see the bank list even if I selected the test environment.
Could you explain how to do it? I tested with other methods and the issue doesn't presents, most probably because you aren't redirected to an external page. The new Sandbox, if you need to check, is: hidden link

January 16, 2019 at 5:38 pm #3098948

rolandS-21

Now you can see, i did some changes, but reinstalling the plugin worked. Thank you for not forgetting me.

January 17, 2019 at 9:32 am #3101051

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks to you, and sorry again for the delay. Now the tickets it's in the working line I should have news soon.

January 17, 2019 at 5:02 pm #3103101

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we think the problem is with the redirection. Making the payment you go to an external site, and then you are redirected back. We couldn't find an option to set the returning URL in the plugin so at the moment we can't suggest anything.

Since the Makecommerce authors say they're compatible with WPML, maybe you could contact them and ask for more information we could use. We're available to cooperate with them to solve the issue. We have our GoGlobal program for this https://wpml.org/documentation/theme-compatibility/go-global-program/ but eventually if they don't want to apply we may communicate directly

January 17, 2019 at 5:09 pm #3103145

rolandS-21

Thank you, I will get in contact with them, it may take some time.

January 17, 2019 at 5:19 pm #3103237

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

It's not a problem, just remember that if there are no replies the tickets may be closed in a couple of weeks.

February 27, 2019 at 6:09 pm #3251872

rolandS-21

My issue is resolved now. Thank you!