Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by saschaN-5 1 month, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 18, 2019 at 8:42 am #4593829

saschaN-5

Update WPML to version Version 4.2.8 on WordPress WordPress 5.2.3. The update seems to work normally but afterwards the original language articles on the page are no longer available in the frontend. The articles are still there in the admin, they are published. But in the frontend they give a 404.
The original content of the page is in German, the translation is English. The English articles are still available on the frontend, even when the original German articles aren't.

Other German original language content, like events, isn't affected.

I tried un-publishing and republishing an article. I tried emptying the cache. I tried resaving permalinks. I tried resaving UberMenus. I tried accessing the content via the page id (i.e. ?p=3210) and it redirects to the permalink and then gives a 404. I tried accessing via redirects we created and the redirects work, redirect to the URL and then I get a 404.

I tried deactivating all WPML plugins. Then the German articles can be accessed on the frontend, but not the English translations, obviously.

There is a second server, a dev server, where I did the same updates. There, everything seems to work normally. Both instances have the same php version, wordpress version, plugins. It's just that I didn't import a newer dump of the database from production to the dev server. When I made a diff of the database schema of test and dev the only difference are 3 tables pertaining to a plugin (Download manager) that is no longer in use.

Link to a page where the issue can be seen:
hidden link
Not accessible externally, I need to figure out how to provide credentials

I expected to see: the article

Instead, I got: a 404

September 19, 2019 at 6:45 am #4601707

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

I will help you with the issue.

I am not exactly sure about the reason for the issue. Please follow the below steps
- Deactivate all NON- WPML plugins check if the issue still persists.
- If the issue disappears, Activate the plugin one by one to isolate the conflicting plugin

If the issue still persists after deactivating all NON- WPML plugins,

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Let me know the results.

Kind regards
Raja

September 19, 2019 at 10:39 am #4603705

saschaN-5

Hello,
thank you for your reply!

I couldn't deactivate all plugins other than WPML. I needed to keep:
* Advanced Custom Fields PRO, otherwise the page won't load at all as our theme depends on it.
* Custom Post Type UI, as the articles in question are custom post types

With everything deactivated but wpml plugins and these two and after I re-saved the permalinks the page loads correctly.

It appears to be a problem with these plugins:
Gravity Forms
Gravity Forms Email Verification Addon
Gravity Forms Multilingual

I updated
Gravity Forms Version 2.4.12
Gravity Forms Multilingual Version 1.5.1

at the same time as the WPML plugins.

I just really surprised as I thought these two plugins are compatible.

I will also try to load an older version of both Gravity Form plugins to see if that changes anything.

thanks!

September 20, 2019 at 4:42 am #4609761

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, Sure I will await your finding. Also please check if there is anything in the debug logs. If the issue seems to be related to the Gravity Form plugin also check if the issue still persists when new content is created on the site or it happens only to the existing content.

Let me know your findings.

September 20, 2019 at 9:44 am #4611077

saschaN-5

A downgrade of
- gravityforms to 2.4.11
- gravityforms-multilingual to 1.5.0

didn't change the problem. Original language articles are still not available on the frontend, but the english translation is.

It's the same for newly created articles and their translations.

Here's the pastebin of the debug.log: https://pastebin.com/qdufnWap

https://pastebin.com/qdufnWap

September 20, 2019 at 5:31 pm #4613905

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

There is nothing much useful in the debug logs, It would be better if you can send me a snapshot copy of your site so that I can look into details about the issue. You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/.

I have enabled private fields for you to securely share the details

September 23, 2019 at 12:02 pm #4623465

saschaN-5

One more thing:
When I save the permalinks, the article page I then reload works fine. As soon as I reload the page it gives a 404 again. I tried saving the permalink and then loading the page in an incognito window (i.e. not logged in) and the result is the same: 1st try: page loads, reload of same page: 404.

I will update with a duplicate package soon. thanks

September 23, 2019 at 2:18 pm #4624919

saschaN-5

The permalink issue gave us another avenue to investigate.

I saved the permalinks normally. then I changed the database user to one with read only rights. When I reload the page with this read only db user, the following query is run:

UPDATE `wp_options`
SET `option_value` = ''
WHERE `option_name` = 'rewrite_rules'

because it's a read-only user, it can't be executed successfully. Because it's not executed, the page loads correctly.

As soon as I change it back to the regular user, the problem comes up again. In this case the same query is executed, successfully, followed by another query that updates the rewrite_rules option. I just compared the rewrite_rules in the wp_options table before and after this update and the only difference is this piece is this:

s:20:"gravityformsapi/(.*)";s:33:"index.php?gfapi_route=$matches[1]";

is added to the rewrite rules after the page reload.

I mentioned the dev server before, where everything works normally, despite being identical except for the database, which is older. I just went through the same process on the dev server and the update query for rewrite_rules in wp_options doesn't run at all on this server when I re-save the permalinks and the re-load the page.

September 24, 2019 at 10:19 am #4630529

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the detailed investigation,

To conclude the rewrite rules added by gravity form seems to be causing issues with your live server? could you pass on the duplicator package for your site if you still need assistance in this case? So that I can run some tests in my local environment and let you know the results.

Private fields enabled for the duplicator package.

September 26, 2019 at 5:03 am #4643479

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am checking on this now, I will update you in a while.

September 26, 2019 at 2:47 pm #4647845

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience,

The issue seems to be resolved with the latest version of WPML version 4.2.9. I have tested it with the duplicator copy of your site and verified the same with Gravity form active.

We are releasing the updates in a phased manner so you might not see the update notice, In case if you don't see the update notice in the plugins list Goto Plugings > Add New > Commercial click "Check for updates" This will show you the latest version that needs an update.

Update all the WPML plugins to the latest, This would solve the issue for you.

I hope that helps you better.

September 27, 2019 at 8:50 am #4652401

saschaN-5

My issue is resolved now. Thank you!