This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Davide 12 months ago.

Assigned support staff: Lauren.

Author Posts
October 10, 2018 at 9:09 am

Davide

I am trying to: moving the website to a new URL hidden link from the old URL: hidden link

Link to a page where the issue can be seen: hidden link

I expected to see: The new website working properly

Instead, I got: A blank page in both admin a frontend

After moving the website (from the old URL: hidden link ) and properly installing everything, I got this error:
--
We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Table 'giovannidamiani_db.lf_icl_strings' doesn't exist

Array
(
[language] => it
[context] => admin_texts_sb_instagram_settings
[gettext_context] =>
[domain_name_context_md5] => 28253d28f09012e7dd42dd920b04d7a8
[name] => [sb_instagram_settings]sb_instagram_btn_background
[value] =>
[status] => 0
[translation_priority] => optional
[allow_empty_value] => 1
)
---

The only solution is to disable the WPML Plugin.
I attach the URL of the database cloned with Duplicator of the OLD website (not the new one).

October 10, 2018 at 6:22 pm #2805418

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I was able to login and see the error when WPML is activated. I tried to install the adminer plugin so I could look for the string in the database but the site did not allow me access. Please check your database and search for this string: 28253d28f09012e7dd42dd920b04d7a8

If you find it, be sure to make a full backup of your database. Then, try deleting the row with that string. Now, when you activate WPML, do you still see the error?

I also see the error that table 'giovannidamiani_db.lf_icl_strings' doesn't exist. Do you see this table existing with a different table prefix? If you don't see the table at all, please try adding this to your theme's functions.php file and then load the front end of your site one time. Then you can delete the code snippet:

function wpmlsupp_1891_fix_missing_icl_tables() {
    if( function_exists( 'icl_sitepress_activate' ) )
        icl_sitepress_activate();
}
add_action( 'wp_footer', 'wpmlsupp_1891_fix_missing_icl_tables' );

Now, check the database again. Does the table display now? If not, I can try manually adding this for you, but I will need access to the database, either by phpmyadmin or by figuring out how to get the Adminer access working on your site.

Lastly, I see multiple rules in your wp-config.php file regarding debugging. Please remove all duplicates and turn on debug mode so I can check for further php errors.
1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 11, 2018 at 3:05 pm #2808815

Davide

Hi Lauren,
thanks for your help. By the way I still didn't solved it.

I checked the database and it seems that only some tables were imported correctly, while it is missing some WPML tables (I attach a screenshot of the DB).

To recap what I did:
- I tried to import the DB into the phpmyadmin, but the process didn't work as it was interrupted with errors about icl_ tables.
- So I tried to make the import process with the plugin Duplicator, and the import was done (but seems it skipped those tables that were giving erros probably).

Consider that the website is under maintenance mode and we have a backup, so no worries about possible problems.

Last:
- I found the string into the table lf_options into "wpml_notices"
- I have cleaned the wp-config file as suggested.

October 11, 2018 at 4:35 pm #2809138

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the additional info. I removed the login information from your previous post for security reasons. However, even after using those credentials, I was unable to login. I have marked the next reply as private so that you can share access to your database securely.

Also, did you add the function in my previous reply to your theme's functions.php file?

October 11, 2018 at 4:51 pm #2809181

Davide

Hi Lauren,

as I told I don't think it is worth it to try that function on the website because a lot of the WPML related tables seem to be missing. (now I send you the DB screenshot)

What error are you getting with the plesk access?
When you see the first screen of the browser alert regarding the ssl security, just say "allow" and "enter an exception" (the browser should prompt a message similar to this one).
I tried and was able to access.

The user is:
support@wpml.org
new password: (I can't find the option to post private!) How shall I send it?

If you still get blocked, maybe you can send me your IP address to whitelist it.

October 11, 2018 at 6:41 pm #2809531

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have marked the next reply as private so you can add it there. The error I see is "Error: You have entered incorrect username or password."

My IP is 174.107.94.241.

The function I mentioned above creates missing WPML tables, but I see from your screenshot that the table icl_strings is already there, and that is the table that the error said is missing. Are you still seeing that part of the error?

Also, please try checking WPML -> String Translation for any strings under the domain admin_texts_sb_instagram_settings. If you find any, please try deleting them and let me know if this is resolved.

October 12, 2018 at 8:54 am
October 12, 2018 at 7:01 pm #2812944

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending access. I created a copy of your site on my local machine and was able to resolve it by following these steps. Please be sure you have a FULL BACKUP before proceeding.

1. In your database, create a table named lf_icl_string_pages with 3 columns. Attached is a screenshot of the structure for this table, just copy these settings.

2. In your database, create a table named lf_icl_string_urls with 3 columns. I have attached an image of this structure as well for you to copy.

3. Search in your database for the string 28253d28f09012e7dd42dd920b04d7a8. You should find two options. One in the icl_strings table and one in the wp_options table. Delete the rows with this value in both of those tables.

After this, I deleted the debug log, reloaded the site and I am no longer seeing any errors on the site or in the debug log.

Please let me know if you need any further assistance and I will be happy to help.

October 22, 2018 at 8:22 am #2837208

Davide

Hi Lauren,
sorry for the delay, can you send me again the screenshot if the table structure? There was no attachment.

Thanks
Best, D.

October 24, 2018 at 6:16 pm #2847523

Davide

Hi, Can you please send me the instructions screenshot of the 2 tables and 3 columns that I have to create? I had no attachment and so I can't go on and fix it.

Otherwise do you think I can copy those tables from the old website which contained all the tables not broken?

Thanks
Regards