This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by mauroP-23 2 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 16, 2019 at 3:45 pm #4221997

mauroP-23

Dear staff
I am trying to:
Translate a website based on elementor plugin from Italian to english.
I'm in trouble for some days because after i made a search by searchbox in header in English version, the result is redirect to Italian version of website with only Italian result. After that if i click on English flag the system show me the English version.
I create the template translation

Link to a page where the issue can be seen:

You can see the issue here hidden link
you can type for example "Brown rice" in search box upper one or bottom one and you'll redirect to italian search page with no result, click on eng flag and you'll see the result with english title.

I expected to see:
that i still in same language site.

Thanks
M

July 17, 2019 at 3:55 am #4225741

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Meanwhile, could you please try to enable Ajax filtering at WPML > Languages > Language filtering for AJAX operations. Then click 'Save'.

Please enable the option: 'Adjust IDs for multilingual functionality' at WPML > Languages > Make themes work multilingual

Also, please try preserving URL arguments. Please review this documentation below:

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

Please let me know how it goes.

Kind regards,
Dennis

July 18, 2019 at 1:11 pm #4238925

mauroP-23

Dear Dennis
Thanks for your help, i follow the step you tell me but unfortunately didn't work.
I upload some picure but you can try directly on website
1- I open site and switch to Eng (or automatic switch)
2- In the search box i write Brown and press the lens
3- the response result is in the italian page of search and it can't find Brown word
4- I switch to Eng english Flag and the response result is english page with 1 result.

Wating for reply
thanks for your help
Mauro

July 18, 2019 at 5:27 pm #4241415

mauroP-23

Dear Dennis
Thanks for your reply, i follow the step that you tell me but unfortunately didn't work.
I send you the Debug Info.
Thanks

July 19, 2019 at 4:15 am #4243809

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

July 23, 2019 at 12:53 pm #4266097

mauroP-23

My issue is resolved now.
I uninstall and reinstall all WPML plugin include WPML All Import and change the URL format from ?lang=en to directory /en/ and now seem like that issue is resolved.
Thanks