This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by frankE-13 5 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
April 21, 2019 at 10:07 pm #3652975

frankE-13

I recently updated the WPML plugins as well as WooCommerce. Since then the site runs only in the default language (de) but not in the second language (en). It is not limited to WooCommerce but to the whole site.

If I switch to the second language or call a page in the second language, it is sometimes displayed and only when calling another page there are problems. Sometimes there are problems directly with the first call. Error log:

[21-Apr-2019 19:27:58 UTC] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /homepages/3/d771504016/htdocs/fotoecke/wp-includes/class-wp-hook.php on line 77
[21-Apr-2019 21:26:40 UTC] PHP Warning: Use of undefined constant ICL_SITEPRESS_VERSION - assumed 'ICL_SITEPRESS_VERSION' (this will throw an Error in a future version of PHP) in /homepages/3/d771504016/htdocs/fotoecke/wp-content/plugins/wp-seo-multilingual/plugin.php on line 15

WordPress, WooCommerce and WPML are up to date. The WPML WooCommerce Multilingual is updated to version 4.6.0.

I had already bought into another ticket: https://wpml.org/forums/topic/site-broken-after-update-of-woocommerce-and-woocommerce-multilingual/

What can I do? I'm losing customers!!!

April 22, 2019 at 10:50 am #3655255

frankE-13

@itamar,
here is my ticket regarding my post in: https://wpml.org/forums/topic/site-broken-after-update-of-woocommerce-and-woocommerce-multilingual/

April 22, 2019 at 8:14 pm #3658105

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @franke-13, welcome to the WPML support Forum!

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

All the best,
Diego

April 23, 2019 at 8:30 am #3660571

frankE-13

Hey, Diego, thanks for the answer.

Unfortunately, the migration failed, for whatever reason. Can you please delete the transferred data, thank you!

I noticed today that the problems only occur when I am logged into the website with the respective browser. If I log out in the frontend or backend, everything works as usual.

When logged in, I cannot switch from default to English. If I choose the second language from the menu (frontend) there is an http 500 error after 30sec (max executiontime).

Anyway, it has something to do with WooCommerce (v3.6.1). I just deactivated WooCommerce and the problems are gone! After the activation of WooCommerce the problems are back!

best regards, Frank

April 23, 2019 at 8:40 am #3660825
frankE-13

I don't know if it's connected or not. But I (and some others) have problems with a plugin "Pay Pal Plus". Since the WooCommerce update to 3.6.1 this plugin doesn't work anymore. I had to switch back to an earlier version of "Pay Pal Plus".

It seems that there has been a significant change in WooCommerce that might also cause problems with WPML?

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-issue-with-woocommerce-paypal-plus/

April 23, 2019 at 4:57 pm #3666383

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sure, I deleted the data. What is the browser with the issue? That's odd because timeouts are usually related to the server and not with the browser. Could you please clear all caches (Browser, WordPress and Server) and check if the issue still occurs? Could you please also try to increase the time to 45 seconds (instead of 30)?

We released a new version today (for WPML and extensions), which fix some perfomance issues. Could you please update all plugins on your website and check if the issue persist? it seems that you already updated WCML.

Please let me know if it works for you.

I will open a new ticket for the paypal plus issue.

Kind regards,
Diego

April 24, 2019 at 8:27 am #3670369

frankE-13

Okay, the problem is the same with all tested browsers (Opera, Chrome, FF & Edge).
I emptied all cache and disabled WP Super Cache, no changes.
I have raised the max executiontime to 60, no change. The error then comes after 60sec.
Even after the updates the problem remains. As soon as I am logged in, I can no longer change the language in the frontend.

April 25, 2019 at 11:21 am #3681713

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We found a new issue related to the recent versions. It seems that it's the same error of your website: https://wpml.org/errata/timeouts-with-woocommerce-multilingual-4-6-1/

Could you please try the workaround provided on the errata?

Please let me know if it worked for you.

Kind regards,
Diego

April 25, 2019 at 12:48 pm #3682567

frankE-13

No, it didn't help. I made the changes but it stays with the error. Once I'm logged in I can't change the language because of the timeout.

April 25, 2019 at 1:22 pm #3682677

frankE-13

As I have just noticed, the TimeOut problems do not only exist in the frontend. I can't edit pages or posts in the second language. Also here the TimeOut error occurs in the backend. The backend hangs itself completely away.

April 25, 2019 at 2:50 pm #3683637

frankE-13

Hi Diego

Great. The workaround (https://wpml.org/forums/topic/upgrading-to-wc-3-6-1-with-wc-multilingual-4-6-0-causes-problems-in-2nd-language/) fixed my problem. Thank you.

April 25, 2019 at 2:51 pm #3683639

frankE-13

My issue is resolved now. Thank you!

April 26, 2019 at 10:27 am #3689741

frankE-13

Just updated WooCommerce Multilingual from v4.6.1 (patched with the workaround) to v4.6.2... the problem is back! I'm back to v4.6.1 again.

What is going on?