This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 10 voices.

Last updated by Pavel 2 years, 2 months ago.

Assigned support staff: Sumit.

Author Posts
March 13, 2018 at 4:16 pm


I am trying to:
Translate a page made with Elementor

Link to a page where the issue can be seen:
hidden link
This is a test page I added and translated just now.

I expected to see:
The exact same HTML around my text

Instead, I got:
A p tag is added around the translated text, which creates a p inside a p, which is invalid HTML, so the CSS classes of the original p tag from Elementor are not applied.

It's the exact same problem as but there was no solution

I tried to disable wpautop with the plugin wpautop control, but it did not help.

March 15, 2018 at 12:02 am #1546442

Ricardo Alday

Hi Frank,

Thanks for contacting support. I can replicate the issue on my test server and I have escalated the problem to our 2nd tier support team. I'll update you as soon as I get some feedback from them.

Thanks for your patience,

April 2, 2018 at 11:33 am #1562166


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


I am Sumit from 2nd tiers support.

This happens because WPML adding WP editor for translation of description which adds a P tag to the text as expected. We have escalated this to replace it with a normal textbox which will fix this issue and should be available in a future release of WPML.
Please let me know if you need a workaround for this.


April 2, 2018 at 12:56 pm #1562248


Hello Sumit,

Thanks for the reply.

So the workaround is to make a custom XML config I guess. You can post it here if you want, for other users with the same problem.

But I don't need it at the moment. The site I am working on has been reduced considerably and I don't have this particular problem anymore.

Thanks for the help, also to Ricardo.


April 5, 2018 at 1:55 pm #1566077


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Frank,

For Elementor, we don't have wpml-config.xml file and we handle it using PHP code.
I am sharing the public issue link in case anyone needs workaround hidden link


April 11, 2018 at 12:24 am #1588268


Thank you Frank, Ricardo and Sumit for posting. I'm running into the same issue supporting translations in Elementor. We are using the 'editor_type' => 'VISUAL' and WPML seems to be injecting P tags. I've also tried to disable wpautop and a custom reverse wpautop function but with no success.

We are using the guide here to translate , all is well except for the p tags.

I was never able to make the editor_type = textarea work (it always renders as a LINE), so I ended up using editor_type = VISUAL. If we can make editor_type = textarea work, that would be ideal.

What do you recommend?

April 25, 2018 at 11:15 am #1807489


I am using a theme (Stratus) with several widgets. Everytime I update the translation with translation manager, new P tags are added that I have to manually delete again. Is there a solution for this ?

May 7, 2018 at 8:30 pm #2020551


There is a typo on the Documentation here

editor_type – This is the type of text field used in the WPML translation editor. Valid values are LINE, TEXTAREA, and VISUAL.

should be

editor_type – This is the type of text field used in the WPML translation editor. Valid values are LINE, AREA, and VISUAL.


This solves the issue we had, fix coming out in our next release. 🙂

May 9, 2018 at 11:41 am #2051233


I have the same issue with Elementor Pro Pricelist widget. It also adds the <p> tags into feature description in translated page. When the fix for this should come out?

September 27, 2018 at 7:07 pm #2771615


Hi, any news about this issue? Is there any workaround?


March 11, 2019 at 9:36 am #3309199


I have the same problem as heikik with the Price list widget. Any modification on the translation of the page add <P> tags on all prices features.
Any news?
We are more than a year after the issue was raised and it seems it's still not fixed 🙁

April 19, 2019 at 11:59 am #3645535


+1 same problem

November 15, 2019 at 2:37 pm #4954815


The problem is still there. Any nes? One year have passed already.