This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Domain per language setting gives "too many redirects" message Solution: Check htaccess for possible redirection rules set for the given domain.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by mahinderS 6 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 5, 2019 at 7:33 am

mahinderS

I am trying to: See the pages that are translated from dutch to english but i get page not found. Also the translated homepage mesa-coatings.com always redirects to the dutch page mesa-coatings.eu

Link to a page where the issue can be seen:

This happens on all the pages

for example: hidden link

hidden link (original language) hidden link translated language english

I expected to see:the translated pages

Instead, I got: page not found

April 5, 2019 at 9:37 am #3542623

mahinderS

I deactivated the domain url's and activated the language as parameter in wpml languages if I activate the domains than the translation doesnt work.

April 5, 2019 at 10:08 am #3542865

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I am seeing "FOUT: Ongeldige gebruikersnaam. Wachtwoord vergeten?" when trying to login with the credentials provided. Can you check this and upload new credentials?

I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

April 5, 2019 at 10:27 am
April 5, 2019 at 11:06 am #3543587

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I was able to log in. I've checked few translated page and none of these point to 404. As for this page:
hidden link

It can't work because it is another language (and Nederlands is default language), so this works:
hidden link

And this is original:
hidden link

However, this part:
Also the translated homepage mesa-coatings.com always redirects to the dutch page mesa-coatings.eu

This would need to be set as per:
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

And you may want to check with your hosting if you have some redirections set and the home page translated as well.

Regards,
Bruno Kos

April 5, 2019 at 11:18 am #3543665

mahinderS

As i mentioned before i already set the translations per domain the problem excits when i do this the domains already point to the website so this is al correct

but when i open a page with the settings translation per domain i get 404

please take a look again

hidden link

April 5, 2019 at 12:03 pm #3543869

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am not seeing 404 - however I get this - redirection error.

Do you have any redirection rules set somewhere for this domain, perhaps in htaccess? Can you check with host/domain registar about this?

Regards,
Bruno Kos

April 5, 2019 at 4:58 pm #3545995

mahinderS

My issue is resolved now. Thank you!