This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 7, 2019 at 7:22 am #4352445

alexL-45

Hi, May i know how can i make the language show on everypage which mean i no need to click to change the language everytime when i open another page. Please view this website mkwin88.com, when i click chinese language on the homepage then i open the menu link it show back english again.

August 7, 2019 at 12:07 pm #4354745

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I visited the site and I changed the language to Chinese, then I tried to click a few buttons from the menu and when I switched the language back to English, it was showing me the right page and it correctly changed the language from Chinese to English.

Can you please elaborate a bit more what is the exact issue that you are encountering? Screenshots or screen recordings might also help me better understand what you mean if you have something like this available.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 7, 2019 at 12:51 pm #4355235

alexL-45

Hi Mihai,

You can try to translate the homepage to chinese language then try to open any menu on the header then you will realize the language change back to english instead of chinese

August 7, 2019 at 3:51 pm #4356593

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

For testing what you said:

1. Please create a full website backup

2. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 8, 2019 at 7:08 pm #4365535

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they worked fine.

From what I can see, the homepage is already translated into Chinese (hidden link) and Malaysian (hidden link).

And for me, it works fine in the front-end too and the menu items are sending to the correct links.

Can you please elaborate a bit more on what exactly doesn't work?

If you can create a screen-recording, that would help a lot.

I will be waiting for your response.

Kind regards,
Mihai

The topic ‘[Closed] After translation successful, how can i make the language on every page’ is closed to new replies.